Combat text not displaying.

Bug Report
I already had the latest WHQL 310.70 drivers installed, but for what it's worth, simply uninstalling the "nVidia 3D Vision Driver 310.70" restored the FCT. Unfortunately, I find that after playing for the past year in 3d going back is not an option. I'll keep looking for a fix when playing in 3d.

I actually saw the FCT go away in Sholazar Basin the other day on my hunter. Previously I had only experienced the problem in Vash. FCT doesn't show unless I lure the mobs all the way to the surface, then it shows up.

The FCT depth on one of the mobs in SB fluctuated wildly coming out of the screen to a perceived depth of somewhere just barely in front of my nose. The FCT was huge, then it fell back into the screen, disappearing into the distance as a tiny pixel. Now I can't see FCT in SB either, with "nVidia 3D Vision Driver 310.70" installed.

Mists added controls for 3d, I had never encountered this problem until then. I wonder whether to blame Blizzard or nVidia for making my FCT disappear. After a complete reinstall/re-download of the game without addons or addon managers I opened a ticket. Blizz blamed addons and closed the ticket without a resolution.

I just opened/reopened another ticket after my experience in SB and finding this thread.

BTW, the FCT shows up when I lure a mob with love taps south into Borean tundra.
This is the reply I received after describing the fix:

Greetings! My name is Keldryck from the Account and Technical Services department for Blizzard Entertainment.

Unfortunately World of warcraft does NOT support the NVidia 3D drivers.

I definitely appreciate you taking the time to contact us! If any other complications come up with your gaming experiences please do not hesitate to contact us in the future for anything that you may need, or. If you would rather speak with a representative directly, please contact Account & Technical Services. Our contact information can be found at <<http://battle.net/support>>.

Sincerely,
Keldryck M.
Account & Technical Services Department
Blizzard Entertainment
Bumping this thread because i am still experiencing issues with damage text inexplicably disappearing during BGs.

I find it extremely bothersome that I had to uninstall nvidia 3d drivers just to get this problem fixed... WoW isn't the only game on my computer and I would very much like to keep my 3D drivers for other games. I currently feel forced to uninstall the driver any time I want to play WoW.

Please address this issue.
I'm gonna bump this too, I'm getting the same issue and it's not my drivers. No floating combat text.

Tried deleting cache and wtf, disabled all addons. No dice.

Addons such as mik and sct work but they suck compared to the default combat text, which places the damage above each mobs head separately, something NO addon can do.

Please advise thank you.
Nothing?
Same problem when using Nvidia 3DTV Play, shame there is no support. Hopefully will be fixed eventually.
I hope a fix does come soon. Even though I am a tank, I still like to see those numbers in an instance, otherwise it feels like I'm not be doing anything. And I would like to keep my 3D for my other games.
Blizzard fix your broken !@#$.. It's always something with you and your 9 year old pay to play beta. if you implement something into your POS game make sure it works.
So my options are no combat text (only noticed no text on my pally in vanilla dungeons) or play farcry 3 and crysis 3 without 3D? I'll keep the 3D and hope blizz fixes this.
I quit WoW 6 months ago because of this issue. I received 7 free days of game time a couple days ago so I figured i'd log in and see if this issue has been fixed...nope. Have any of you guys found a solution to this problem? I really want to play my old rogue but i'm not gonna play without being able to see how much damage i'm doing.
What a silly reason to quit a fun game, I'd hope you tried the steps people suggest in this thread, it's what I'm about to do.
thanks, works, but you don't have to reinstall anything or restart your computer, i just uninstalled 3d vision and restarted wow and it worked perfectly, after a !@#$ing month of no combat damage text i finally got a fix for it
Me being an avid 3D fan and having the Asus VG278H full 3d led monitor this issue with wow is a major pain the ares. If I want the combat text to show up I have to uninstall the nvidia 3d driver every time then when I wan't to play a game in 3d I have to re-install the driver. This is a pain and stupid I like to play wow but this is almost a worth uninstalling the game for wow is not the only game I enjoy to play but it seems it has to be the only game on your computer or you will get issues out the !@# with it.
Ok i'm not a smart person. But i was having this issue on my Druid tank. same as what you guys are talking about. I closed my wow client, opened up my nvidia settings. checked updates, and downloaded/installed the newest thingymajiggy driver. Opened wow up again. works again perfectly. I noticed during the installation that it UNinstalled my old 3d controller, and installed a new version of it. So if you have this problem with an nvidia card. give that a shot.
I had this same problem, i couldn't see the Damage being Done to an enemy or Healing being done to an Ally.. i opened my first ticket a week ago and a GM which was really helpful couldn't tell me what the problem was after deleting my "WTF" and "Cache" folders which was really irritating and annoying i mean who does like to see does Green and Yellow Texts..

So... I started looking for a solution to this issue..

1. Disabled all my addon's and it didnt really help the same issue was being consistent

2. Uninstalled and Installed WOW for about a couple of time and didnt help much i had the same solution i couldnt see my FLOATING COMBAT TEXT.

3. I raid a lot and i couldnt see my Healing Done to Others on SOO so i took another approach... I checked for Newer Nvidia GeForce Drivers and so (I FOUND ABOUT A NEW RELEASE OF DRIVERS)

4. CHECK YOUR NVIDIA GEFORCE DRIVERS if you are still running the drivers 331.82 or 332.21 ( Head to Nvidia.com > Country > Drivers> All Nvidia Drivers > Option1 or 2 and Download the Latest Version (334.89)

It worked for me. cheers
02/21/2014 12:05 AMPosted by Ðârkângêl
I had this same problem, i couldn't see the Damage being Done to an enemy or Healing being done to an Ally.. i opened my first ticket a week ago and a GM which was really helpful couldn't tell me what the problem was after deleting my "WTF" and "Cache" folders which was really irritating and annoying i mean who does like to see does Green and Yellow Texts..

So... I started looking for a solution to this issue..

1. Disabled all my addon's and it didnt really help the same issue was being consistent

2. Uninstalled and Installed WOW for about a couple of time and didnt help much i had the same solution i couldnt see my FLOATING COMBAT TEXT.

3. I raid a lot and i couldnt see my Healing Done to Others on SOO so i took another approach... I checked for Newer Nvidia GeForce Drivers and so (I FOUND ABOUT A NEW RELEASE OF DRIVERS)

4. CHECK YOUR NVIDIA GEFORCE DRIVERS if you are still running the drivers 331.82 or 332.21 ( Head to Nvidia.com > Country > Drivers> All Nvidia Drivers > Option1 or 2 and Download the Latest Version (334.89)

It worked for me. cheers


This made mine go away and now i cant get them back.. :( hoping to find a fix soon lol
Ok, for those who ever, at anypoint, had MikScrollingCombatText or any other addon like it:completely remove it and any saved information from your Addon folder. If that still don't work, like it did'nt for me, move your saved data folder out from the WTF folder, and move your addon zips out as well, completely delete the interface and WTF folder, launch and quit the game to reset all data and then move back your saved info back into the new WTF folder and move back your addon zips as well(don't forget to unzip them :) ). Then upon your next login, go to menu>interface>Floating Combat Text and re-enable your texts that you want to see. Hope this helps those of you who were suffering like me. Good NIght :)
For me, uninstalling the nvidia 3D physics drivers resolved the problem. This is an incompatibility bug between World of Warcraft, and the nvidia 3D physics drivers.

For those who do not meet the requirements to use 3D Vision, simply uninstall the nvidia 3D Physics from programs and features, and your issue should resolve itself. Why Blizzard hasn't fixed this since it was originally mentioned is beyond me... Blizzard is slacking, especially since we are paying them to let us play their game.

Join the Conversation

Return to Forum