Videotron: Cant log in, Stuck as "success"

Technical Support
1 2 3 16 Next
Title. When I click cancel and changes to "Retreiving server list" and stays there.

This is BS! I am paying for this service! How can they let it stay down for this long without fixing it. I want my money back for MoP, Screw Blizzard!!
I tried:
-running as administrator
-checking for updates
-closing everything
-delete folder ( comes back everytime I open the launcher)
Was working 10h hours it doesn't.
Same here was playing last night then stopped for an hour came back and got this.... after trying to login 25 time it lets me in but i get stuck in loading a toon. I've never had a problem with wow since last night.
I unplugged my router and went strait to the modem and still same.
Tried that rename WTF,Cache and Interface folder still same.
Tried a system restore from yesterday morning when it was working and no luck.

It must be on their end.
I hope they fix it soon before Pandoria !!!
Yeah seriously. Still not working. Waiting for a fix.
Having the same issue here. It never happened to me before, and everything was working fine yesterday up 'till ~11pm.

I tried flushing the dns cache, rebooting my router, the usual. Still stuck.


I was able to get one step further after rebooting my modem. I could select a character, but now I'm stuck at 90% loaded, still no Stormwind showing up.
Same here after many attempts to login (20+) i get the character screen and then it loads to 90% and stays there..(
Same thing here. Most of the time, I get stuck at success and Retreiving server list. When I can log, I get stuck at 80% loaded. I tried running WoW as administrator, deleting and WTF folders.
Anyone having this issue could repost with a List of your ISP, antivirus and firewall software.

do you play on wirelsss connection and the model of your modem or router.

this could be a big help.

Also include if your computer's edition of windows and if you have vista or windows 7 do you play with UAC disabled?
Same thing here , i need admin love xxxx please
anyone have any news ? i tried repairing my game and then it ask me to download a patch ... when i open wow launcher i enter my info and then the download starts but when the patch is ready to download it says thats something is wrong and i need to redownload the game and call blizzard if this still dosent work ...

anyone know what is happening ?
same thing here
Just started for me right now!
im on the phone right now , waiting for them to answer me ! ill post when i get any news
09/22/2012 02:52 PMPosted by Harfanoo
Same thing here , i need admin love xxxx please

Blues are all gone for the weekend. I'm likely among the few qualified to help you.

I stand corrected. Looks like there are weekend warriors around after all :)

Maybe Kaltonis will chime in here with a suggestion.
Called a friend, he told me he couldn't log in D3 all day long.

Tried it, it worked for me. I can log in D3, but not WoW. Called another friend, he's able to log into both at the moment. This is really weird.


Spoke too soon. After 10 mins in D3, I got disconnected while chatting over Real-ID, and now I can't login anymore in either games...
same problem.....
i just got off the phone ... The lady told me that redownloading was a good thing but since i am using curse client she told me to delete it from my computer ! she said maybe the addons and programs use are not fitting well with the new patch ! And i told her i had the repair button and she told me that was maybe why ( she said that i had the old version )

This is what i have done :

tried to open when and get stuck on success
tries to dwn a patch and it told my i had to re install all the game again
deleted every wow and curse file on my mac
started new dwn of wow

so : fingers cross and let see after the download
this sucks.. goes for both my games D3 and WoW
Same here, windows7, couldn't log, closed restart logged played 5 mins got dc"ed, stuck at success....

Join the Conversation

Return to Forum