Mount Page Sorting

Bug Report
Okay, so.. This is odd to me. Sometimes when I open my mount window my mounts are sorted alphabetically, and other times it's sorted by type (cats together, proto drakes together, etc)...

How do I sort it and/or how do I stop it from randomly picking >.<
The same thing happened to me last night. It's been sorting by name the whole time, and then suddenly after opening the window only minutes prior, it's switch to sorting by some other method (wasn't looking at the long enough to figure out what method).

I haven't opened it since to see if it fixed itself, and I haven't looked into trying to fix it either.
The same thing happened to me last night. It's been sorting by name the whole time, and then suddenly after opening the window only minutes prior, it's switch to sorting by some other method (wasn't looking at the long enough to figure out what method).

I haven't opened it since to see if it fixed itself, and I haven't looked into trying to fix it either.


I've noticed that this is happening every time you change into a CRZ, it changes the sorting to type, and every time you are back on your 'home realm', it goes back to alphabetical. It's really frustrating, as I use a macro for mounting, automatically choosing a mount based on location, and it uses the position of the mounts in the list to choose the mount. Re-sorting of the mount list by crossing into CRZ really messes that macro up.
This happens to me too. Everytime I zone (CRZ or hearth? havent looked that closesly, but it happens alot). From alphabetical to type. I use a random mount macro too and I am constantly getting ground mounts instead of flying mounts becaue of this =(
Same for me, I like it when it "glitches" tho.
I still have this same problem almost every day, and I do not enjoy this "glitch". Since there is no sort feature on the mount page and my toolbars are all full, it is very aggravating to have to fish through the whole list to try and find a certain mount.
Just chiming in that I'm also experiencing this bug.
Also having this problem. Very stupid and annoying... messes macro's up! asldkfjhadslkfjadslfkjafklsaf<---frustration
I am also experiencing this, but I like when it happens. I wish there was an actual option on the interface to switch this back and forth.
Just adding that this is very frustrating as I have 196 mounts, and I'd also like to add in a request for a search function.
Same issue here, I really wish something could be done about this, does anyone if there is an addon to sort mounts?
I know there is tons of them for the pet tab I would figure it wouldnt be much to make one for mouns but that is a very uneducated assumption.
Anyway if anybody finds one please let me know.

Join the Conversation

Return to Forum