will I be able to run mists

Technical Support
I was just wondering if I can run cataclysm on the good setting will I be able to run mists ok?
Well, can you run 5.0.5 good? It is the same client, and yes you should be fine then.

I play on a crappy laptop atm and I can at least run mists on lower settings.

Join the Conversation

Return to Forum