Black Screen on Alt-tab back

Technical Support
Sometimes when I alt-tab out, upon returning I get a black screen. The black screen sometimes then goes away and enters the game, 5 seconds or so, but occasionally it takes a ctrl-alt-delete and restart. Never a game crash, only on the alt-tab.

I've checked all the drivers and everything is good, including DirectX.

Add-on's updated.

Problem only started after 5.0 release.

Qosmio X505, Windows 7, NVIDIA GeForce GTS 360M, everything is nice and cool
i'm having this problem too...always have to close the whole thing and get back in...this problem is getting annoying...
I have the same issue on my laptop, how do I fix it?

Sony Vaio (Windows 7 x64 licence). 6 GB RAM / Intel i7 (1.73)
If you guys are using Win7 -- Try turning your Theme to Windows Basic, this fixed it for me.

IE: Right click your desktop, personalize, choose win basic!
Another suggestion: Try playing in Fullscreen Windowed mode, it's basically the same as Fullscreen except less likely to bug when you alt-tab.
Still a problem.
workarounds that seem to work for me...
if you just entered a dungeon or something, walk backwards out of the dungeon. you will be able to see a loading screen again.
also, type /camp and you will log out. you will then be able to see your character selection screen once your character logs out. yes, it will be a blank screen but type it in anyway. wait 20 seconds.

this usually happens to me in pandaria, but not in other parts of the world, like say, northrend or outland or something. just pandaria.
I know it happens
There are two mini solutions to the problem.
1. Play in Windowed (fullscreen)
2. Just type /reload

Number 2 seems to work but you just have to wait for the loading screen to go away and thats it.

Playing on Sony Vaio laptop too.
Necropost.
Recently stepped on the same issue - black screen after alt+tab or even on game start.

Solution:
It happens when the refresh rate and/or the resolution of WoW and desktop are different, that black screen is a delay to rerender window in a different setting (WoW and actual desktop). Switch framerate to the same value as your screen works.

Join the Conversation

Return to Forum