Slow fresh MoP install using game dvds

Mac Technical Support
i agree, this is a horrible experience. Its not enjoyable, all we as consumers wish to do is to install the game sit down and enjoy the awesum game that you (blizz) have produced. But firstly we have to sit through the endless crap of half DVD install half internet install and (in my personal opinion) a bit of spontaneous generation and dumb luck and just hope that the 4 hour installation goes correctly otherwise we'll be repeating the process again :(
After encountering repetitive error 134s or something with the game, I wrote several tickets and followed the instructions with no luck of fixing the problem. Deciding it would be best to do a fresh install I uninstalled, only to find my CD rom drive driver was corrupted. I'm the opposite of a genius and sparing the details, an hour of effort later I managed to reinstall the disc drive and finally began the setup process. People have been saying it's supposed to ask for the second disc at about .3%? Mine's at 1.1% as I type this and still on the first disc. Could this be a potential problem? I didn't check for any straggling folders or files after I uninstalled WoW and am thinking maybe a leftover folder or file could potentially ruin my install and make me re-install all over again? Would like to know before I spend the next two days fixing Blizzard's game only to have to repeat the process.
This entire thing is just confusing to me.
I started installing this at 11am-12pm today,
it is 4:30pm now.. I've only put disk one in.. and its 69.5%..
I've been looking for answers as to why it is so slow, I'm not getting much.
Whatever. ._.
Blizzard. Just let us download the complete latest build directly if the current media install is going to be so useless. I've downloaded several full installs off of Steam this week, each over 8GB and taking very little time over 50Mbs cable. Why does your update infrastructure *still* run so poorly?
This thread is several months old. I have not been on WoW for months, but I am having the same issue installing on my Mac - it's been going for hours, and is just d/l data, not taking much off the disc, which is in the drive (supposedly) to avoid having to d/l data. Shouldn't this issue be fixed by now? Or is Blizz, still, after all these years, as bad as they always have been?
I know this is an old thread, but i just got the battlechest a week ago, and already downloaded the sterter edition. I did a system restore, so my wow files were deleted from mycomputer, i popped in the disc to do the manual install, and it is taking much longer than the download?
yeah i'm running into the same problem with my MoP CE dvd's. Did a clean restore on my PC and now 3 hours later its at 1.1%
I am experiencing a similar issue. The only thing is it is past .3% and hasnt asked me to put in disc 2 yet. Its still installing extremely slow. I dont have any of the WoWs installed on my PC anymore and havent played in a really long time. Basically since Cata.
Having the same problem. My internet is generally slow, due to the mass array of electronics sucking up wifi. I noticed the new installer gives you ZERO information on what it is downloading. This is very User-Unfriendly, I must say. Blizzard, you yet continue to push the consumers buttons.
Hour 2 of this wretched wait and only 1.5 percentile. SMDMFH @Blizzard
well ok i know this is a bit late but im only installing now i installed upto wotlk and it downloaded some random crap i did have cata but accidently threw the disk away so i thought ok let it dowload cata the next thing i know is that everything is mop i was like ok so i went ahead put mop disk in it says checking for updates then it goes to launcher and starts downloading 18gig i was like wtf why 18g patches aint that big just uninstalled and attempting to install all from the mop disk its at 5.6% and hasnt asked for disk 2
I've been through hell and back with trying to get back into this game.

It's been two years, randomly decide to reinstall and see what's up.

I installed the game client. Up to Cata (as I didn't yet have MoP), Took 18 hours.
I moved the "World of warcraft" Icon to my made new folders. Got freaked, moved them back.
Long story short. I corrupted data. I tried everything said. Nothing worked.
I decided I would just go get mists and see what happens.
I deleted everything related to WoW. Everything in "Users" Everything in Preferences, everything in the trash was emptied.

Loading discs, I get to 0.4% And then I get this error:

This application has encountered a critical error:

ERROR #1 (0x13370001) Fatal Exception
Program: /Users/Shared/
Exception: short exception


Crashed Thread: 0x00009287


Whaaaaat the actual hell.

I've had no luck. No luck in my attempts at troubleshooting with Blizz/ support. No luck at anything regarding this install.

It should not be this difficult.
I tried installing this expansion on my old 13 year old computer when the expansion first came out. It has been through a lot and over the past month started giving me the BSOD so when i went to install MoP on it and saw it was taking forever at 0.3%, i exited the install and assumed it was my crap computer being well.. crappy.
Today, however, I got my custom built brand new tower up and running and now that ive finally installed all the previous expansion (fresh install), i am now still experiencing the same exact issue on a overly capable, up-to-date rig.

Theres obviously no fix but are there any actual answers as to why this ocurs? Ive read once it gets passed 0.3% itll ask for disc 2 and zoom by, but im currently at 0.9% and still creeping by...
I've been sitting here watching the History channel...even took a slight nap. I'm at 0.4% and no asking for disc 2 yet.

2010ish 13" Macbook pro. Fresh install. I've ran Cata before on this with no issues.

I mean, if it will eventually work, I'm okay with that. What I'm not okay with is the misinformation of numbers during the installation. Before digging through google I had all but given up because it was so off on numbers.
I got to 2.1% after well over an hour and got an error message and was forced to restart the install...wth
I have a solution turn off indexing its what is causing all the problems go to your hard drive and right click properties and on the bottom uncheck indexing.
Turned off my indexing and downloaded the client from battlenet. Installing the game now...I think. Currently at 5% and no prompt for disk change. I have the disk in, but I believe I'm downloading straight from the client.

When I tried downloading straight from the disk, it seemed to have halted at 16.8%. No prompt ever popped for a disk change. I went outside and snowblowed my driveway, went to the nearby convenient store, and went to a dinor 8 miles from my home to pick up a food order. THE PERCENTAGE DID NOT CHANGE. I seriously believe the disks are poorly formatted. is currently at 7.8%. 19GB remaining. I sure hope it's not just patch notes.
Same problem. =/
Yeah, not fun. At least I'm glad I found this thread so I know I'm not alone. My motherboard crashed and I had to basically start fresh with a new laptop so I have to reload the game from the DVDs. It's been well over an hour and I'm only at 0.9% and it hasn't asked me for disk 2 yet. I just tried the indexing trick so we'll see if that helps.
This is lousy as it gives you no info on what is actually happening. I just get to watch screen shots of random MOP bunnies and wildlife scenery.
Blizzard, how about a little info on this download page like, "don't fret valued customer....your download will be done about 34 hours....hang in there and remember....your subscription fee is paying for your time spent NOT playing the game!"

Ok. As soon as I submit this my download goes to 1.1% and it asks for disc 2. I guess complaining does help you out in life sometimes. I gotta remember to tell my mother that someday.....
I purchased a new computer which means installing the game again. I do not remember having this much of a hard time the first time around but this time it doesn't seem to matter if I use the discs or try to install it from the website I am stuck for over an hour and a half now trying to download mists.

Join the Conversation

Return to Forum