Mist of Pandaria Discs won't install the game

Mac Technical Support
Same here purchase new box of mists of pandaria and it won't load keeps going on to the agent update n it won't load at all.
I'm having the exact same problem as well. The first time I attempted to install MOP, it made it to 0.4% before saying "Failed to download a required update. Please check your internet connection." I just uninstalled the game and tried to to download again. The launcher would not go past 0% and I received the same error message. Using the discs to install did the same damn thing. Please help.
Same here purchase new box of mists of pandaria and it won't load keeps going on to the agent update n it won't load at all.

Battle.net files do have to get properly updated before you can download.

Try this :

1) Restart

2) Download this zip file :


3) Unzip it and drag the battle.net folder to :

Mac HD -> Users -> Shared

Replacing what's there.

Also delete any Blizzard folders you see there in /Users/Shared (ie Blizzard or Blizzard Entertainment)
I was having this same issue, I just delete all of my wow folders, and started a compete fresh install. Worked like a charm.
this is crap,it should be just a matter of installing dvds then download and play,after all it's costing us a lot of money, please fix it wow
Ran into this today. I was trying to do a fresh install of MoP from the retail disc on a newly formatted 2009 MBP.

The hurdles I ran through:

1) Install from the retail disc--watch my CPU run at 99c and fans at 6000rpm for hours while the install snailcrawls (I did not have this problem on my 2008 MBP or my Win 7 box--not sure what this MBP's deal is).

2) Install from the launcher--download 20GB and risk my ISP giving me garbage about bandwidth limits, not to mention the time sink and the hit my latency will take while I play WoW on my Win7 box in the meantime.

3) Wait 45 minutes while I transfer the 24GB WoW folder from my 2008 MBP onto an external hard drive, then wait another hour while it transfers off the external HD on to the 2009 MBP. Should work in theory, but it's still transfering.

Needless to say, the reason I buy the retail disc every xpac is so I don't have to go through this madness. :/
i can log into my wow account off of a different computer, i called wow support team and they couldnt figure out why when i log in i get a error #107 no game attached or may be in a different region i deleted my chache files wtf files and everything else over the phone with the tech support guy and nothing has happened now my computer is saying that launcher cannot get patch information check internet config i have a HP pavillion g series. Does anyone know how i can fix this issue if not i figured i would just refund my money back, i bought the deluxe package off like 4 days ago and yet to play it i dont have much time to be messin with the computer to get it fixed anyway cause i work alot. So can anyone help me out on this one?
wtf i just purchased wow Mists Of Pandaria Collectors addition and put the disks in and i understand everything and ik its just a launcher but i cant get the mists of pandaria download up and i have Macbook Not the Macbook pro just regular Macbook :l plz help i just wanna play i guess im a noob and i cant figure this crap out
nvm guys got it

Join the Conversation

Return to Forum