How to recreate the MBP Retina low FPS issue

Mac Technical Support
I've figured out how to recreate the low frame rate problem on my MBPR.


1) Connect the power adapter to the MBPR. Make sure the light on the connector is turned on.

2) Reset SMC to clear the problem. Press the Shift-Control-Option keys (on left side of built-in keyboard) and the power button at the same time.

3) Turn on the MBPR.

4) Run WoW and login. The frame rates should be normal. Make a note of the FPS. Notice how the fans spin up loudly.

5) Put the MBPR to sleep by closing the lid.

6) Disconnect the power adapter.

7) Wake up the MBPR by opening the lid. I left it awake for about 10 seconds.

8) Put the MBPR to sleep again by closing the lid.

9) Connect the power adapter. Again, make sure the light on the connector is turned on.

10) Wake up the MBPR by opening the lid.

11) Run WoW and login. The FPS will now be about 1/3 of normal. Also notice how the fans barely spin up.

If you command-tab out of WoW, the entire Mac feels laggy. Menu bars drop down more slowly than normal. Dragging and resizing windows in other applications also suffer. As soon as I quit WoW the Mac feels normal. WoW will continue to have the FPS problem until I reset the SMC again.

The usage pattern that I've described above is one that I do all the time. At my house, I use the MBPR while connected to a thunderbolt display which provides power. I sleep the MBPR, disconnect it from the thunderbolt display, and take it out of my house. I use it away from my house on battery power. When I'm done I put it to sleep then go home. After I get home, I reconnect the MBPR to the thunderbolt display while it's still sleeping. I then wake it up using an external touch pad. I go to play WoW and get terrible frame rates. I reset the SMC and all is well. Until I repeat the pattern again the next day.

I'm pretty sure this started after I applied the 10.8.2 and firmware updates.
Thanks for the report.

This seems like similar to the sleep/wake bug that was around in 10.7+. This was a Mac bug that affected all OpenGL applications.

Have you reported this to Apple?
I haven't but I will. What's the most effective way to report this? Post it on Apple's support forums? Call for technical support?
Exactly the same issue is happening with me on a 2010 Macbook Air 13". I have been reduced to 10fps. Doing the SMC reset as above and leaving Macbook Air open (I usually use cinema display in clamshell), I was able to get back to between 40-50fps - a significant improvement.

Currently using latest Mountain Lion patch (10.8.2 - 12C54).

I can submit to Apple, but it seems everyone I know is sharing the same issue regardless of Apple hardware or version of OS X.

We've all noted problem in the latest patch of Wow - as opposed to any variation in the Apple software/hardware.

I suspect it's a Blizzard client issue given it's the only constant.
For those who have varying hardware, the SMC reset is documented here:
Revisiting this as we're looking into these specific reports, can you recreate this issue with just the built-in display and no other peripherals connected?
I'm glad I found this post I my FPS has dropped just like that; I'm going to try this method now.
you don't actually have to reset the SMC for this bug. simply restarting fixes it. nothing more needed. it's an OS X bug that affects wake from sleep opengl performance..
Yes the issue can be recreated with just the built in display, and no peripherals attached.
This thread has been extremely helpful for me. I have a 15" MBP Retina and experienced a huge drop in FPS suddenly (from around 45 FPS on medium graphics settings, to around 15 FPS). Restarting the computer did not solve the problem, but a reset of the SMC did solve it.
10/26/2012 05:41 PMPosted by Omegal
you don't actually have to reset the SMC for this bug. simply restarting fixes it. nothing more needed. it's an OS X bug that affects wake from sleep opengl performance..

This has not been my experience. Rebooting does not fix the problem on my MBP Retina; SMC reset was the only way.
MacBook Pro Retina 15" Mid 2012 (MacBookPro10,1), 2.6 GHz Intel Core i7, 16 GB 1600 MHz DDR3, OS X 10.8.2 (12C3006)

Ridiculously low frame rates.

What I noticed was that the problem was most common after I connect either of my external displays (at work or home) via the Thunderbolt/DVI adapter, and then disconnect them... I don't play on or with the externals attached. The next launch of WOW was almost certain to have low frame rates, and I had to perform the SMC reset to get frame rates back to acceptable levels.

Note: If I was having the low frame rate issue, it affected all games. Diablo III was almost unplayable without resetting the SMC and WOW's frame rates were in the low teens if not less than 10.

I have added steps to this regimen, which I haven't seen anywhere else on the forums, that has kept the problem away for almost a week now, even when switching from one display (at home), to another (at the office), with the machine sleeping in between. The added steps were removing some windowserver.plist files, and resetting SMC & Parameter RAM afterwards. This is supposed to be the fix for no video out to a projector or other device via TB to VGA adapter (which happened to me the other day).

Note: You'll need to hold down [option] while on the 'Go' menu to see the Library folder
Reset SMC ([shift]+[control]+[option]+[power])
Reset PRAM by powering on the machine then holding down [command][option]+P+R through 3 startup chimes.

Hopefully this doesn't come back... but this combo has kept it away for quite a while now.
I spent 2 hours trying to figure out the problem. Thought I would never get it. Till I read this thread - thank you!
The original poster described exactly what I had done - and what caused the problem. The solution posted here worked!
Just saw this problem, and fixed it with the manual SMC reset. Reboot did not fix it.

MBPro 2.6 Core i7, OS 10.8.2. I make extensive use of external monitors, connected over DVI through a Thunderbolt adapter, and frequently change the external monitor config before, during, and after putting the laptop to sleep.

If there's something I can do to help narrow this one down please let me know.
I can confirm also that the SMC reset works. Took me from 15-20 fps all the way back up to my 45fps cap. RMBP.

Try it, it works.

Edit: Thank you to those responsible for figuring this out. Made my day. :)
To add more data points to the discussion, I found this thread from a Google search as I'm having this very issue with Borderlands 2. MPBr 15", 2.6 i7, 16GB RAM, 10.8.2. Resetting the SMC fixes it. I only need to close the lid, disconnect the power and my FPS is toast.
Yeah it's a nasty apple bug that they have been blowing off since 10.7 shipped. the bug first presented in 10.7 and has been an issue since and not just for 2012 macs but actually almost all macs running 10.7. some graphics chipsets seem immune but most ati and nvidia i've seen suffer from this issue when running 10.7 or 10.8. Apple has been mute on it cause they could probably give a rats behind unless it's affecting their precious iphone or ipad games. Only thing that matters for macbook's is battery life and if they can connect to app store/itunes. (can you tell i'm more than a little annoyed a bug like this has gone unfixed for nearly 2 years). Even my 2008 mac pro is affected by issue. I'm just fortunate enough merely rebooting resolves it. SMC resets aren't needed on all machines. just 2012 ones it seems. Any older mac affected needs only reboot or change desktop resolution once then change it back.

I truely don't envy the position a bug like this puts companies like blizzard or steam through who have a great deal of fps reports created because of this.
the interesting thing is I did not have any FPS problems until MoP
12/23/2012 09:47 PMPosted by Alwaysnever
the interesting thing is I did not have any FPS problems until MoP

always, your issue is likely not related to the APPLE bug the OP of this thread is discussing. Your issue is off topic (in THIS thread). Hopefully mack can resolve your issue in the relevant topic.
I could reproduce this apple issue all of cataclysm. I could also reproduce it in steam games, and opengl extentions viewer. The 10/7/10.8 sleep bug affects ALL opengl applications.
Does this APPLE bug affect all macs or just laptops?

also I remember an fps related issue back in wrath. I had to edit a line referring to opengl and the problem was solved.

I was hoping this was going to be that simple.

oh well Im sure mack will come along and spank me for being bad lol

just trying to get to the bottom of this as I would really like to get back to playing

happy holidays everyone

Join the Conversation

Return to Forum