What should my FPS be?

Mac Technical Support
The last few weeks I have noticed a sharp decline in my FPS like some others Mac users have.

I've read through a few FPS topics on here to try and gauge but I've seen people with Macs weaker than mine that perform better and vice versa. I'm far from a Mac expert so I wasn't sure if my performance is normal. I run on recommended settings which is "High"

I used to get about 60-70fps. I'm now hovering around 20, usually averaging about 18-19 in cities and even questing in Tol Barad. If I am in a deserted place it will rise to about 30. Its a 2010 IMAC and I believe its still very up to date. I could use more ram but could that be my problem?

This is driving me crazy because the difference is very noticeable. If anyone could tell me if this performance is normal for my machine or if I should be getting more out of it I'd appreciate it!

* I have taken the steps listed in other topics such as deleting the cache and battle net folders, moving the WTF files ect with no difference

__

OPERATING SYSTEM:
MacOS 10.8.2
CPU TYPE:
Intel® Core™ i3 CPU 550 @ 3.20GHz
CPU SPEED:
3.22 GHz
SYSTEM MEMORY:
4 GB

Chipset Model: ATI Radeon HD 5670
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: ATI (0x1002)
Device ID: 0x68c0
Revision ID: 0x0000
ROM Revision: 113-B9850H-133
EFI Driver Version: 01.00.416
Displays:
iMac:
Display Type: LCD
Resolution: 1920 x 1080
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort
Have you tried doing a SMC reset ?

http://support.apple.com/kb/HT3964?viewlocale=en_US

It's possible that some stray voltage somewhere is causing this
Have you tried doing a SMC reset ?

http://support.apple.com/kb/HT3964?viewlocale=en_US

It's possible that some stray voltage somewhere is causing this


Thank you for the reply.

I have tried that, as long as I'm doing it right. I had never heard of it before but was expecting something more complicated than:

Shut down the computer.
Unplug the computer's power cord.
Wait fifteen seconds.
Attach the computer's power cord.
Wait five seconds, then press the power button to turn on the computer.


I followed the directions but unfortunately saw no change.
Not sure if it'll help but try doing a PRAM reset :

http://support.apple.com/kb/HT1379

If that doesn't help can you copy/paste an edited copy of your config.wtf. Edit your account name out of it. It's in the WTF folder.
We're investigating the low FPS reports. I'll keep y'all posted on the results. Thanks for the reports.
PRAM and SMC reset HELP MAJOR... i'm only getting 20-30 FPS on Ultra and highest Rez for my retina... normall got 40-45... but its a fix for now. Thank you.
PRAM and SMC reset HELP MAJOR... i'm only getting 20-30 FPS on Ultra and highest Rez for my retina... normall got 40-45... but its a fix for now. Thank you.

Have you tried doing a SMC reset ?

http://support.apple.com/kb/HT3964?viewlocale=en_US

It's possible that some stray voltage somewhere is causing this


Thank you for the reply.

I have tried that, as long as I'm doing it right. I had never heard of it before but was expecting something more complicated than:

Shut down the computer.
Unplug the computer's power cord.
Wait fifteen seconds.
Attach the computer's power cord.
Wait five seconds, then press the power button to turn on the computer.


I followed the directions but unfortunately saw no change.


Try the other one with the battery you cant remove... what computer do you havE?
I'm having the same Issues, esp in Pandaria.

Model Identifier: MacBookPro8,2
Processor Name: Intel Core i7
Processor Speed: 2 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: MBP81.0047.B27
SMC Version (system): 1.69f3

Chipset Model: AMD Radeon HD 6490M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
there are quite a few threads regarding fps issues that just recently cropped up and still no word other than to try this or that all of which have yielded no help. I would much more appreciate blizzard coming clean about something they may have done that is causing this so we dont waste our time playing techs on our end. I hope it gets resolved soon as its made playing unbearable.
Bump

Join the Conversation

Return to Forum