Stuck in Panda Starting more quests

Bug Report
I was leveling this character with my refer-a-friend and we finished a quest and went to turn it in Aysa Cloudsinger...
We were both able to turn it in, but only my friend got the next quest...,_the_Spirit_of_Air

I have no active quests. Quest giver has nothing for me. I tried tracking low level quests. Tried going back to the previous quest giver. Nothing.

Blizz ticket is 3 days eta =[
wah =[
This sucks, i've looked EVERYWHERE for a quest >___<;;;;;;
I'm stuck on this damn Turtle foreeeever....
bump, still stuck...
There is a totem pole that gives a quest in Fe-feng village. Once you accept and complete that quest, you can progress onward.
Thanks alot helped me a lot haha
I got stuck too... but after running back and jumping on the last wagon... riding it again... jumping over the wall to get out of the city, and finding no quests outside with the horde... and teleporting back inside to the inn... running back to the wagon again but this time looking for a totem pole with a quest... but this time there was a quest on the guy standing next to the gong. After that quest was accepted, another appeared over a close panda who quested me to get wood planks.

I took this newly appeared quest, killed the rabbit, took the hammer, took the wood, gave the wood back, gave the hammer back, hit the gong with the hammer, waited... started looking around... after 20 seconds he had a new quest to use Shu on the Earth spirit to wake him up. Then it seemed to start flowing quests again.
I'm currently on the quests where you run around and grab bamboo as a frog and I turned that one in but I didn't get the quest to continue on when you fight the trainees on the poles... I can't find it anywhere. D:

Join the Conversation

Return to Forum