WoW kills my sound

Technical Support
for the last 2 days, when the game starts after the launcher, my sound has been going out and all sound related programs freeze if running (itunes, youtube etc.) the first day of MoP was fine, but now i get nothing. i can restart my computer and all sounds and sound related programs are back to normal, until i launch WoW. i've gone through all the steps i could find from previous posts about sound problems (i.e. removing cache, wtf and interface folders etc.) but still get nothing. here is a link to a post from the EU forum with what sounds like the exact same problem... http://eu.battle.net/wow/en/forum/topic/5347485632
Hey dude, I got the SAME problem. I'm using a Logitech G930 headset, which is pretty unreliable as is. But, I notice at random times when I'm playing the sound gets all crunchy then goes out. Then in Media software like Winamp, or even on Soundcloud, the files wont play (stay at 0:00). It's really bothersome. Hope a fix comes soon!
I have the same problem. Usually within seconds of entering the game, all the sound goes out. Then if I leave the game, all the sound stays out for any other program, game, media center and etc. The only way to get the sound back is to turn off the computer and unplug it from the wall. Just rebooting the computer doesn't fix it, since this "error" does not allow the computer to turn off completely. This only happens with WoW!

At first I though it might be an incompatibility problem with my Creative Titanium HD card. I then turned on the SoundMax integrated sound that was on the motherboard and the exact same thing happens. I am using all the current drivers and have even tried reloading them after these problems occured.

This is making questing difficult as many of the quests rely on verbal instructions (ie, the "Reports" quest chain from the Pearlfin village).
Lichkilla,

Lets get some more information on your set up. Go in to the World of Warcraft/Logs folder and post the contents of your sound.log file.
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!
Here is the sound log from my computer ( this was the only file in that folder with "sound" on it). After entering the game, it took about 8 secs before the sound stopped. I am running windows 7 64-bit.

9/27 15:45:05.343 => SI3 Init
9/27 15:45:05.343 => WoW Version 5.0.5 (16057) Sep 10 2012
9/27 15:45:05.353
9/27 15:45:05.353 => User Settings Report:
9/27 15:45:05.353 - ========= PLAYBACK =========
9/27 15:45:05.353 - Enable All Sound [1]
9/27 15:45:05.353 - Enable SFX [1]
9/27 15:45:05.353 --- Enable Error Speech [0]
9/27 15:45:05.353 --- Enable Emote Sounds [1]
9/27 15:45:05.353 - Enable Music [0]
9/27 15:45:05.353 --- Loop Music [0]
9/27 15:45:05.353 --- Pet Battle Music [1]
9/27 15:45:05.353 - Enable Ambient Sounds [1]
9/27 15:45:05.353 - Sound at Character [1]
9/27 15:45:05.353 - Sound in Background [1]
9/27 15:45:05.353 - Enable Reverb [0]
9/27 15:45:05.353 - Enable Software HRTF [0]
9/27 15:45:05.353 - Sound Quality [2]
9/27 15:45:05.353 -
9/27 15:45:05.353 - ========== VOLUME ==========
9/27 15:45:05.363 - Master Volume [0.60]
9/27 15:45:05.363 - SFX Volume [0.90]
9/27 15:45:05.363 - Music Volume [0.00]
9/27 15:45:05.363 - Ambience Volume [0.90]
9/27 15:45:05.363 -
9/27 15:45:05.363 - =========== MISC ===========
9/27 15:45:05.363 - Sound Channels [64]
9/27 15:45:05.363 - Use Hardware [1]
9/27 15:45:05.363 - Mix Mode 2 [0]
9/27 15:45:05.363 - DSP Buffer Size [AUTO]
9/27 15:45:05.363 - Armor Foley SFX (Self) [1]
9/27 15:45:05.363 - Armor Foley SFX (Others) [1]
9/27 15:45:05.363 => End of User Settings Report
9/27 15:45:05.363
9/27 15:45:05.363 - SE3 Init...
9/27 15:45:05.363 - FMOD Memory Init
9/27 15:45:05.363 - FMOD System Create
9/27 15:45:05.363 - Setting Output Type
9/27 15:45:05.393 - 6 Output drivers detected
9/27 15:45:05.393 --- [0] System Default
9/27 15:45:05.393 --- [1] Speakers (Creative SB X-Fi)
9/27 15:45:05.393 --- [2] SPDIF Interface (SoundMAX Integrated Digital HD Audio)
9/27 15:45:05.393 --- [3] SPDIF Out (Creative SB X-Fi)
9/27 15:45:05.393 --- [4] Speakers (SoundMAX Integrated Digital HD Audio)
9/27 15:45:05.393 --- [5] Digital Output (SoundMAX Integrated Digital HD Audio)
9/27 15:45:05.393 ** Using User Specified Driver [1] Speakers (Creative SB X-Fi)
9/27 15:45:05.413 - DSPBufferSize = AUTO DETECT
9/27 15:45:05.413 - Setting DSP Buffer Size
9/27 15:45:05.413 - Using Control Panel Speaker Mode STEREO
9/27 15:45:05.413 - Setting Software Format (44100, 2, 2).
9/27 15:45:05.413 - Requested 64 channels.
9/27 15:45:05.413 - Initializing Hardware Channels
9/27 15:45:05.413 - Sound Driver Reports: 0 Hardware Channels Available.
9/27 15:45:05.413 - ###########################################################################################
9/27 15:45:05.413 - # NOTICE: No Hardware Channels Available.
9/27 15:45:05.413 - # Microsoft dropped support for hardware channels in Windows Vista and Windows 7.
9/27 15:45:05.413 - # If you are not using Windows Vista or Windows 7 and you are still seeing this,
9/27 15:45:05.413 - # it means your audio hardware/driver doesn't support hardware channels.
9/27 15:45:05.413 - ###########################################################################################
9/27 15:45:05.413 - Initializing Software Channels
9/27 15:45:05.463 - Init FMOD Game System
9/27 15:45:05.463 - Ok
9/27 15:45:05.463 - Setting Rolloff Scale
9/27 15:45:05.463 - Setting Rolloff Callback
9/27 15:45:05.463 - Sound Bus Init
9/27 15:45:05.463 - Init Suppressors
9/27 15:45:05.503 - SE3 Init Success.
9/27 15:45:05.503 - Setting device callback
9/27 15:45:05.503 => SI3 Init Complete.
9/27 15:45:05.503
9/27 15:46:29.143
9/27 15:46:29.143 => Shutting Down SI3
9/27 15:46:29.143 - Shutting Down SE3
9/27 15:46:29.183 - Shutting Down SE3 COMPLETE.
9/27 15:46:29.183 => Shutting Down SI3 COMPLETE.
9/27 15:46:29.183
Lichkilla,

MPQ files are data files for the game. That's where the game stores the sounds it's playing. The Lock file is only used for patching or optimizing and shouldn't be there. Are there any other .lock files in your data folder? Are you starting the game from the Launcher or running directly from the wow.exe?
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!
Gobie,

Your sound log shows you're attempting to enable hardware sound when your system is not capable of using hardware sound.

In the sound section of the game system options, uncheck the box for 'Use Hardware' and then save and close the game. You'll need to restart the game entirely before that change takes effect. Let me know if you still have sound issues afterwards.
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!
1st let me thank you for your time helping me troubleshoot this !! I appreciate it no mater how this turns out :)

I'v tried every combination: 32bit or 64bit, hardware on and off, DX9 or DX11, 24 to 64 channels, Creative or Soundmax makes no difference.
With the hardware off, I got about 3 secs of sound this last try

Here is the log from the last attempt,
9/27 16:52:55.181 => SI3 Init
9/27 16:52:55.181 => WoW Version 5.0.5 (16057) Sep 10 2012
9/27 16:52:55.181
9/27 16:52:55.181 => User Settings Report:
9/27 16:52:55.181 - ========= PLAYBACK =========
9/27 16:52:55.181 - Enable All Sound [1]
9/27 16:52:55.181 - Enable SFX [1]
9/27 16:52:55.181 --- Enable Error Speech [0]
9/27 16:52:55.181 --- Enable Emote Sounds [1]
9/27 16:52:55.181 - Enable Music [0]
9/27 16:52:55.181 --- Loop Music [0]
9/27 16:52:55.181 --- Pet Battle Music [1]
9/27 16:52:55.181 - Enable Ambient Sounds [1]
9/27 16:52:55.181 - Sound at Character [1]
9/27 16:52:55.181 - Sound in Background [1]
9/27 16:52:55.181 - Enable Reverb [0]
9/27 16:52:55.181 - Enable Software HRTF [0]
9/27 16:52:55.191 - Sound Quality [2]
9/27 16:52:55.191 -
9/27 16:52:55.191 - ========== VOLUME ==========
9/27 16:52:55.191 - Master Volume [0.60]
9/27 16:52:55.191 - SFX Volume [0.90]
9/27 16:52:55.191 - Music Volume [0.00]
9/27 16:52:55.191 - Ambience Volume [0.90]
9/27 16:52:55.191 -
9/27 16:52:55.191 - =========== MISC ===========
9/27 16:52:55.191 - Sound Channels [64]
9/27 16:52:55.191 - Use Hardware [0]
9/27 16:52:55.191 - Mix Mode 2 [0]
9/27 16:52:55.191 - DSP Buffer Size [AUTO]
9/27 16:52:55.191 - Armor Foley SFX (Self) [1]
9/27 16:52:55.191 - Armor Foley SFX (Others) [1]
9/27 16:52:55.191 => End of User Settings Report
9/27 16:52:55.191
9/27 16:52:55.191 - SE3 Init...
9/27 16:52:55.191 - FMOD Memory Init
9/27 16:52:55.191 - FMOD System Create
9/27 16:52:55.201 - Setting Output Type
9/27 16:52:55.221 - 6 Output drivers detected
9/27 16:52:55.221 --- [0] System Default
9/27 16:52:55.221 --- [1] Speakers (Creative SB X-Fi)
9/27 16:52:55.221 --- [2] SPDIF Interface (SoundMAX Integrated Digital HD Audio)
9/27 16:52:55.221 --- [3] SPDIF Out (Creative SB X-Fi)
9/27 16:52:55.221 --- [4] Speakers (SoundMAX Integrated Digital HD Audio)
9/27 16:52:55.221 --- [5] Digital Output (SoundMAX Integrated Digital HD Audio)
9/27 16:52:55.221 ** Using User Specified Driver [1] Speakers (Creative SB X-Fi)
9/27 16:52:55.241 - DSPBufferSize = AUTO DETECT
9/27 16:52:55.241 - Setting DSP Buffer Size
9/27 16:52:55.241 - Using Control Panel Speaker Mode STEREO
9/27 16:52:55.241 - Setting Software Format (44100, 2, 2).
9/27 16:52:55.241 - Requested 64 channels.
9/27 16:52:55.241 - Initializing Software Channels
9/27 16:52:55.291 - Init FMOD Game System
9/27 16:52:55.291 - Ok
9/27 16:52:55.291 - Setting Rolloff Scale
9/27 16:52:55.291 - Setting Rolloff Callback
9/27 16:52:55.291 - Sound Bus Init
9/27 16:52:55.291 - Init Suppressors
9/27 16:52:55.321 - SE3 Init Success.
9/27 16:52:55.321 - Setting device callback
9/27 16:52:55.321 => SI3 Init Complete.
9/27 16:52:55.321
9/27 16:53:57.371
9/27 16:53:57.371 => Shutting Down SI3
9/27 16:53:57.371 - Shutting Down SE3
9/27 16:53:57.421 - Shutting Down SE3 COMPLETE.
9/27 16:53:57.421 => Shutting Down SI3 COMPLETE.
9/27 16:53:57.421
Gobie,

I'm not seeing any other issues in the sound log.

When switching to the integrated sound, did you uninstall the other sound drivers?
________________________________________________
Technical Support
Want to speak with someone directly? http://us.blizzard.com/en-us/company/about/contact.html

Check your G-diffuser system!
9/27 19:08:30.533 => SI3 Init
9/27 19:08:30.547 => WoW Version 5.0.5 (16057) Sep 10 2012
9/27 19:08:30.574
9/27 19:08:30.589 => User Settings Report:
9/27 19:08:30.607 - ========= PLAYBACK =========
9/27 19:08:30.622 - Enable All Sound [0]
9/27 19:08:30.640 - Enable SFX [1]
9/27 19:08:30.656 --- Enable Error Speech [1]
9/27 19:08:30.682 --- Enable Emote Sounds [1]
9/27 19:08:30.697 - Enable Music [1]
9/27 19:08:30.715 --- Loop Music [0]
9/27 19:08:30.731 --- Pet Battle Music [1]
9/27 19:08:30.749 - Enable Ambient Sounds [1]
9/27 19:08:30.764 - Sound at Character [1]
9/27 19:08:30.790 - Sound in Background [0]
9/27 19:08:30.805 - Enable Reverb [0]
9/27 19:08:30.824 - Enable Software HRTF [0]
9/27 19:08:30.824 - Sound Quality [1]
9/27 19:08:30.857 -
9/27 19:08:30.872 - ========== VOLUME ==========
9/27 19:08:30.890 - Master Volume [0.00]
9/27 19:08:30.915 - SFX Volume [1.00]
9/27 19:08:30.930 - Music Volume [0.40]
9/27 19:08:30.949 - Ambience Volume [0.60]
9/27 19:08:30.949 -
9/27 19:08:30.982 - =========== MISC ===========
9/27 19:08:30.997 - Sound Channels [24]
9/27 19:08:31.024 - Use Hardware [0]
9/27 19:08:31.039 - Mix Mode 2 [0]
9/27 19:08:31.057 - DSP Buffer Size [AUTO]
9/27 19:08:31.072 - Armor Foley SFX (Self) [1]
9/27 19:08:31.090 - Armor Foley SFX (Others) [1]
9/27 19:08:31.105 => End of User Settings Report
9/27 19:08:31.132
9/27 19:08:31.154 - SE3 Init...
9/27 19:08:31.182 - FMOD Memory Init
9/27 19:08:31.225 - FMOD System Create
9/27 19:08:31.254 - Setting Output Type
9/27 19:08:31.307 - 3 Output drivers detected
9/27 19:08:31.322 --- [0] System Default
9/27 19:08:31.340 --- [1] Speakers (Logitech G930 Headset)
9/27 19:08:31.356 --- [2] Digital Audio (S/PDIF) (High Definition Audio Device)
9/27 19:08:31.374 ** Using Driver [0] System Default (Speakers (Logitech G930 Headset))
9/27 19:08:31.428 - DSPBufferSize = AUTO DETECT
9/27 19:08:31.454 - Setting DSP Buffer Size
9/27 19:08:31.491 - Using Control Panel Speaker Mode 7.1
9/27 19:08:31.540 - Setting Software Format (44100, 2, 1).
9/27 19:08:31.565 - Requested 24 channels.
9/27 19:08:31.580 - Initializing Software Channels
9/27 19:08:31.644 - Init FMOD Game System
9/27 19:08:31.665 - Ok
9/27 19:08:31.680 - Setting Rolloff Scale
9/27 19:08:31.698 - Setting Rolloff Callback
9/27 19:08:31.698 - Sound Bus Init
9/27 19:08:31.731 - Init Suppressors
9/27 19:08:31.788 - SE3 Init Success.
9/27 19:08:31.834 - Setting device callback
9/27 19:08:31.914 => SI3 Init Complete.
9/27 19:08:31.940
9/27 20:38:56.151
9/27 20:38:56.194 => Shutting Down SI3
9/27 20:38:56.209 - Shutting Down SE3
9/27 20:38:56.265 - Shutting Down SE3 COMPLETE.
9/27 20:38:56.281 => Shutting Down SI3 COMPLETE.
9/27 20:38:56.299
========================================================

My sound keeps breaking if I am using Skype or Pandora, while playing the game. It's odd, I completely disable all my sound in-game and it wont work
Make sure you are using the sound HARDWARE option in game. Also lower the number of channels you are using for WoW ( If wow is tring to access too many sound channels it will conflict with any other program using your sound card. ) lastly lower the quality of the game sound. I had this happen a few years back and have NOT had it happen since. This was all I did.

Join the Conversation

Return to Forum