Razer Naga + Modifier Keys don't work.

Mac Technical Support
I have my bottom left and right actionbars set to shift+1 - 12 and alt+1 - 12. I can shift/alt click them with the keyboard, but it doesn't seem to be working with my naga. My mouse buttons work perfectly fine with my PC so I know that's not the issue. When I click them, they register 1 - 12. When I apply the modifier, it doesn't register control, shift, or alt, but it still registers the 1 - 12 buttons. I've been playing on my mac a little more because it's handy to have a laptop, but it's very annoying when I have a lot of bindings that I can't use.

TL;DR: In short, the shift/alt/control keys don't work with my naga. But the normal 1-12 buttons do.
P.S. 1 - 12 means 1 thru = on keyboard.

Would like to know if others have this problem! Thanks.

P.S. 1 - 12 means 1 thru = on keyboard.

I'm confused, so are you saying shift/alt/control are bound to keys on the naga?
No, I have the naga buttons set to default. I didn't change any bindings. It's just when I use shift/alt/control in combination with using the naga, for example, shift+1, it will not register the shift, only the 1.
And you've downloaded the latest drivers from Razer? I remember this was an issue before, but Razer updated their drivers.
I'm having this same problem. The modifiers will not register.
Alright, so I already had the Naga Epic driver installed, but I went to the razer site and reinstalled the Razer Synapse 2.0 software and now everything is working as it should.
Idk if u tried this but make sure the switch on the back of the naga is set to 123 not num... if its set to num it cant have mods
I am having a similar problem, however...

http://imgur.com/h9RPn

I downloaded Razer Synapse, and this is all that shows up. I've tried uninstalling and re-instaling it several times, and it still doesn't work. Any suggestions? I've looked everywhere and can't find a solution. /:
I got a similar problem...I've read some posts, all scattered around forums about this, but none fixed my problem. I just bought a Razer Death Adder, looking forward to bind Alt / Ctrl to buttons 4 and 5. I downloaded the Razer software, configured my mouse the way I wanted it, entered Wow to try it, and boom, nothing. The buttons aren't modifying anything. I deleted all addons, erased all my macros, reset all key bindings, tried the Terminal copy / paste thing, still nothing. What can I do to use mouse buttons 4 and 5 as Alt / Ctrl / Shift? And yes, I am a Mac user.
I am having same issue ...
you can go here:
http://pqrs.org/macosx/keyremap4macbook/index.html

and download the keyremap4macbook program, install it and the modifier keys will work again
I've noticed default keybinding doesn't work on the Naga, but I've got modifier keys working under the Bartender Add-on.
I too am still having the same infuriating issue.
Try signing up for Razer Synapse. http://www.razerzone.com/synapse2 . It worked for me!
you can go here:
http://pqrs.org/macosx/keyremap4macbook/index.html

and download the keyremap4macbook program, install it and the modifier keys will work again


thank you, this literally just worked for me.
you can go here:
http://pqrs.org/macosx/keyremap4macbook/index.html

and download the keyremap4macbook program, install it and the modifier keys will work again


thank you, this literally just worked for me.


Me too!!! randomly stopped working 2 days ago and just tried this...bingo! Thanks again.
Eh, a better solution is to disable the wow hack that breaks modifiers in first place than adding even more software.

http://us.battle.net/wow/en/forum/topic/10310891547#8

Also, not sure how you ended up on this thread instead of one not even a full page down. When do a search, maybe sort by date so you don't find out of date threads/solutions. :)
No clue how u found this solution but it worked....Do you have any idea what caused the issue? I had my kid in my lap and he hit some button combo and it screwed everything up.
There's an easy way to fix this with just razer synapse and no addons. You simply use the macros in razer synapse.

Go to macros, create a new macro by clicking the '+' and entitle it Numpad 1. Select default delay and set it to whatever you want (i use 0.050 sec delay). then click record and press 1 on the side of your razer naga once, then click stop record.

Go to Mouse and under customize select "go to side view". click the tab for NUM to switch to the numpad tab instead of normal keys (123), then select 1. Under button assignment select macro, then assign the Numpad 1 macro you just made and under Playback option select "Play while assigned key is pressed". Voila, modifiers now work for that key.

You can use this same method for enabling modifiers for all other Numpad keys, and for any of the 1-0 keys on your naga. I personally setup these macros for both sets so modifiers work for both modes. Hope this helps.
I don't know how you figured this out, but it works...too much time spent on this. can I play game already?!?! thank you :)

Join the Conversation

Return to Forum