Key wont work!!

Customer Support
1 2 3 6 Next
I just bought the digital deluxe edition card and it says i cannot claim the code when I try to enter it. Anyone have any ideas? Im following the directions on the card and getting rather annoyed that i just paid $60 for something that doesnt work.
An error has occurred.
The code you entered cannot be claimed. Please check the code and try again. If you see this error again, please try again later, as the game or website may be undergoing maintenance.

This is the message I keep getting!! Im very frustrated.
Well you are not alone, I am having the same issue. Where did you get it from?
Same problem here. I got mine at WalMart
09/25/2012 12:47 PMPosted by Kopey
Same problem here. I got mine at WalMart

First, it's important to rule out any sort of browser issue. Clearing your cookies/cache - trying another browser usually resolves that, if that is the issue.

Next, if at all possible - have someone else read the code while you input it. Many digits can look a lot alike and those codes are VERY long.
I have tried to clear out my cookies and had someone else read the numbers out...nothing! I used both ie and google chrome, nothing!
I also got two cards from walmart. One for me and one for someone else.
Tried both browsers, cleared everything, tried a "2" as a "Z" still getting the same message
How about trying Mozilla Firefox? I highly recommended it over IE or Chrome when inputting codes such as the Authentication Key.
Also, don't use IE10 on Blizzard's account management site, because they don't play well with each other =(
same problem card purchased from target for digital deluxe version. receipt says "activation successful"

Tried different browsers doesn't make a difference. Chrome, Firefox
verified the code multiple times.
hasn't worked for me yet but from a similar thread

"ok finally got it I just kept trying over and over again"
i am getting the same thing, tried different browsers. and even computers with no luck ...
same here :(( and I got mine from Wal Mart
Hey blue people, can you give us a hand? I would hate that i spent 100 bucks for two cards and have wasted a lot of money! (60+60)
09/25/2012 02:17 PMPosted by Shakufa
Hey blue people, can you give us a hand? I would hate that i spent 100 bucks for two cards and have wasted a lot of money! (60+60)

This is being looked into.

Can I ask what URL they asked you to enter this into?
i've been getting the same thing and tried clearing cookies, different browsers and now get a "tried too many times error. to add further insult to the injury, customer support line queue is full and hangs up on me >.<
i am going to stop trying for right now... do not want to get the to many times error ... seems to be happening with most everyone that gets it ...
The URL they gave me was
Gonna take a shot in the dark here...based on nothing and probably totally wrong.

My collector's editions for me and my spouse both worked just fine, from Best Buy.

I went to the account page from the link HERE on the forum and logged in, then went to summary tab, highlighted the account I wanted to upgrade, and in the lower right of the whole web page I saw a pandaria upgrade box, one of which had the option to add a game key. I took that, and saw it said spaces and hyphens were not necessary. Looking at the game box insert I saw the letters were all caps.

So, not wanting to take chances, I put caps lock on and didn't put in any spaces or hypens when I typed it in...typed it all as one massive string of jumbled letters and numbers with no breaks.

Worked just fine, both boxes.

Something to look out for, Capital letter B and digit 8 look almost identical in the font they are using on the inserts that have the keys on them. If you see what you think is a B or an 8, look extra hard and make sure you are choosing the right thing to type. C's and G's are a little similar too. (added edit: a later poster said 2 V's one right after another look like W's...another thing to be on the lookout for. Long story short, stare hard at that key to make sure you really are seeing the characters you think you are seeing).

So...long story short, one method to success is caps lock, leave out hyphens, and make sure the font isn't confusing you and making you type the wrong thing.

Guessing that there may be a web page bug and either they don't recognize lower case or they don't like hyphens or spaces and are treating those as part of the code if you actually type them, resulting in the code being interpretted wrong by the web page. Just a guess. If anyone finds that to be true, or figures out font was confusing them, please post back your success story for others in case they are having the same problem.

Join the Conversation

Return to Forum