Where are my Reinforcements bugged

Quests
The quest in Kunlai Summit "Where are my Reinforcements?" is still bugged.
I tried abandoning, relogging, exiting, reloading ui...
Now I can't even retake the quest.
Not bugged, just doesnt show him on quest tracking, you can find him right in front of the monastary with a white bubble above his head.
This is still bugged, I have tried logging out, and everything, I tell him I'm ready, we run up the hill, and he disappears, I don't get the credit for telling him I'm ready, I'm using a hunter, I have my pet dismissed, and I'm on Bladefist.
Same thing for me... Seems to be as of 5.2. I get the quest ok, I tell him I'm ready to leave, I don't get credit for telling him but he runs up the hill anyway. If I follow him he gets to the balloon then disappears... I've tried disabling addons, logging, abandoning... Nothing
I figured out a workaround... Just ride up to the monastery yourself and talk to him there... Then you'll get the credit for that...THEN go back down to the balloon and he will be there and you can talk to him and ride the balloon.
Thank you Presidia, that worked.
Some of these bugs are silly, as are the work arounds, but thank you Presidia. It worked.
Thank you Presidia, it worked for me as well. I've been trying to find workarounds to this for an hour.
Thanks Presidia!
another way to fix which i worked out is to ride up the hill to the monastery, tell him your ready and get credit for it, then tell him your ready again and you will jump in the balloon, it bugs and just goes vertical then down again but its a short-cut from running down hill again :P

Join the Conversation

Return to Forum