Weird sound issue - spell sounds looping

Mac Technical Support
Lately during the game I have to go into the sound button and say click headphone mode on and off the get spell sounds to stop looping? It happens a lot lately. I have played around with settings no help yet.

Thanks K
Weird... Can you try nuking some of the temp files and rebuild game caches and see if it helps?
Does this mean anything important?

04:53:29.8386 Detected corruption for MD5 block #0, amount = 16384
This is nearly a brand new macbook I looked for temp that windows advice?
For all the people mostly Mages and some Warlocks who are going nuts with looping spell noise and have to go in and click on and off deathknight voices or change settings and can't find anything about it in US Forums or at Apple...

"Greetings Kathleen,

Thank you for getting back to us. This is a known issue and is being looked into. As a temporary workaround you can disable the Death Knights Voices option. From reading in the forums it appears that adjusting the number of channels from low to high has fixed thsi for other players. Here is the forum topic that I am referring to:

Hopefully this provides you some relief from this issue as a permanent fiz is getting worked on. Please have a great and hopefully less repetitive day!

If you have additional questions or concerns, please reply to this ticket. If you would rather speak with a representative directly, please contact Account & Technical Services. Our contact information can be found at <>.

Thank you,"
I am having the same problem. Sounds like the Arcane Blast sound is on one long cast...
Yup. Water elemental is constantly winding up for what must be a BIG cast.
I have this issue too. The only temporary fix is to go into sounds settings and toggle the use hardware check box. The sound will still come back though

The casting sound for frost bomb gets stuck and play on an endless loop.

The only way to stop it, is to either completely exit the game and reload, or change the game output option back and forth. However this is only a temporary fix since it occurs again, sometime instantly.
09/28/2012 02:17 PMPosted by Machkhan
Weird... Can you try nuking some of the temp files and rebuild game caches and see if it helps?

Actually, I have this same issue of persistent spell sounds. Nothing I do with the files fix this... though switching audio output sources temporarily fixes it. Not sure if this works for anyone else.
I have this issue too. The only temporary fix is to go into sounds settings and toggle the use hardware check box. The sound will still come back though


Toggling any of the following options should make the sound system restart stopping the sound.

* Death Knight Voices
* Use Hardware
* Reverb option (not sure of exact name)
This is unacceptable. Blizzard has known of this issue for a while. Fix it now have people playing for the entire experience, sound being part of it.
Same issue in windows. Set up boot camp to fix the trash performance after the patch, and still get the sound looping.
I was shocked that I could not find anything about this issue until i put several tickets in and someone finally had some mercy.

Yes, going to sound, clicking on and off hardware mode does work but it's inconvenient while in combat.

It's still happening every day I have tried different settings, combo's, etc. nothing seems to work. I even dl'd warcraft back to my see if that was the issue. It wasn't, still happens often every day.

If someone hears about a solution. Please post it. I am looking at this post often.

Thanks, Katea
Can y'all post some system specs so I can send this to the appropriate team?

    1. Launch World of Warcraft and log in.
    2. Put World of Warcraft into Windowed Mode if it is not already in Windowed Mode.
    3. From the system menu bar, select Help > Copy Support Information:
    4. Paste the contents of the copied system information here (Command-V)

System Software Overview:

System Version: Mac OS X 10.7.4 (11E53)
Kernel Version: Darwin 11.4.0
64-bit Kernel and Extensions: Yes
Time since boot: 3 days 37 minutes


Hardware Overview:

Model Name: iMac
Model Identifier: iMac12,2
Processor Name: Intel Core i7
Processor Speed: 3.4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 16 GB
Boot ROM Version: IM121.0047.B1F
SMC Version (system): 1.72f2


AMD Radeon HD 6970M:

Chipset Model: AMD Radeon HD 6970M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 2048 MB
Vendor: ATI (0x1002)
Device ID: 0x6720
Revision ID: 0x0000
ROM Revision: 113-C2960K-152
EFI Driver Version: 01.00.507
Resolution: 2560 x 1440
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort


Input Source ID:
Keyboard Layout: ANSI
I can confirm this issue. it seems to be related to very specific sounds

here are sound si ca recall off top of my head

turtle mount /mountspecial action sounds tend to get stuck in a loop, often with a strange delay.

mage talent (the arcane dot one forget name) tends to get stuck in looping sound after mob dies.

others I can't think of off top of head.. I've never tried to reproduce em, just happened to notice it always happening to same sound events.
I also can confirm this issue.

The hissing issue will always comes on when I cast any spell on my Mage. (Fixing it is basically toggling your sounds - But it will come back when you cast your next several of spells).

But it rarely comes on my when I am playing other characters.

Maybe it is mainly a Mage's issue?

But anyway, I want to thank you "Blizzard" ahead of time for finding a solution for us.
I think it is a Mage and sometime Warlock issue...
It's definitely only occurring on my Mage. I'm frost, and my elemental is looping it's casting sound. It makes no difference if I dismiss him, if I'm mounted (and he vanishes), nothing. Once the loop starts, it don't end, man.

It's amazingly frustrating. I realized how tranquil and serene a lot of Pandaria is when I leveled my Druid. Made me sad that I missed that the first time through. Please, please find a fix.

*edit: iPhone thinks "elemental" should be "electable" - this political season just won't leave me alone

Join the Conversation

Return to Forum