Cannot learn any new alchemy recipes

Bug Report
I picked up the new Zen Master Alchemy, but any trainer i visit cannot give me new recipes to learn to level up the skill, and I cannot see any higher level recipes at all.
bump, very important issue
I'm not sure if this is a bug. I have the same issue and I think it might be that we have to find the alchemy trainer in MoP land.
worked fine for me.
Every other profession has all their recipes in stormwind, I don't see why alchemy would be any different.
i also have zen and canot see the new stuff
you have to discover new stuff by making alchemy stuff. this worked just fine for me.
Also, make sure to click the dropdown at the top of the trainer window and select all the options there, just to be sure.
There were only like 2 new recipes that I could learn when i trained zen rank, but some text in the alchemy tab said to create the potions to learn new ones, so i made the Restore 60k health potions with the tea leaves I had herbalized while out in pandaland, and before i knew it I had like 8 new recipes. Also got the quest to make the Alchemist stone trinket, but people charging 1k+ for a single Golden Lotus are out of their damn minds. But I digress, maybe just try */reload ui* or something like that.
i cannot whatsoever get any new recipes. i learned zen, leveled up with previous expansion recipes and now...nothing :/
agreed, I even have the zen alchemist stone. I know we are suppose to get like two recipes and discover the rest, but what are the recipes, becuase like others on the thread I only got the zen master alchemy and no new recipes.

EDIT Found them***** ok so my sis did some looking and the recipes are there for me but at lvl 500 not 525. it's master's healing potion, and alchemist's rejuventaion. since I left some recipes not purchased it blended in with those. Hope this helps anyone else who can't find the recipes.
Oh good, i'm going to go look for that as well. I was baffled, but thought i had to go find the recipies somewhere out in the world. Thanks for the update!
Yeah, I was fooled at first too, but once I read the fine print on the two new potions I could make, I figured it out. You learn some by making some. A neat concept, really.
Personnaly there was a real bug for me. I had the recipes but they did not show in my list. I was able to see them thanks to the search option. The bottom window would show the recipe but it was invisible in the list, I could see the green highlight and nothing was written. Everything went back to normal once I searched for them. Now I can see them fine.
Just took Shakra's advice, and did a search on my existing recipes.... once you type in the name of them, they pop up, and stay there.... Took me 2 weeks to figure this bug out... glad its fixed

Join the Conversation

Return to Forum