[Quest] To the Rescue! Bugged, uncompleteable

Bug Report
The quest "To the Rescue!" in Ashenvale (starts at Mor'shan Ramparts in Northern Barrens) is currently broken. When you talk to Kadrak he says:

"Brutusk is out watering the bushes right now.

Stay close though, <player name>. He should be ready for our ride to Splintertree very soon."

Your only option is "I will check back with your shortly, Kadrak."

However, Brutusk is already spawned, and waiting any amount of time changes nothing. I have tried relogging, dropping and reacquiring the quest, and disabling all my addons, but I am unable to continue the quest (and thus unable to continue Ashenvale progression).
I did this 60 levels ago on this character and it was bugged then. The way we got through it was getting a high level alliance to kill Kadrak - then when he respawns he is reset and you can continue with the quest as normal. ATM this is the only way to get past this quest that i know of. It has been bugged for ages, would be nice to see it fixed :-)
I've got the same thing going on. I reported the bug (in game), but you can't do more than two quests in Splintertree without doing this one first, so it kind of ruins the whole area...
Yeah this has been bugged for a very long time and its the key quest to continue in ashenvale,really surprised it hasn't been fixed :(
Its been bugged for me too. I abandoned the quest did multiple future quests went back re accepted the quest and it worked. Hope this helps
Quest is still bugged - trying to do it. :(
Fix this stinkiing bug! It's been since April of this year and it's still not working. What is wrong with you people. Get the game working. You don't seem to mind taking our money so how about giving us what we pay for!
You've had too many complaints to leave it unfixed.
Yeah this is kind of silly - two different realms - why is this still a 'bugged' quest since April??????
I've been trying to do this quest for two days now. Tried multiple ways around it that I've found here and several other sites. Still getting the "he's watering the bushes" comment. Then you put in a ticket and it's a 2+ day wait time. Exactly what are they doing up there. I don't live all that far from Irvine. Keep wondering if I have to drive up there to get support in person or something.
still bugged......
but i dont have a high enough alliance character
Still bugged...
hello people

i know this is an old post but this problem is not fixed and i cannot continue questing with this character while the problem is not working tried different ways of how to do it but still having a problem can someone help me or will Blizzard just fix this bug

thank you

Join the Conversation

Return to Forum