Cant log in after Restart...

Area 52
Anyone else having this isuue?
Yep. I am. Says Area 52 is up, can't log in. Can't even get to the login area where you would change realms. I'm just stuck at "Connecting".
Im having the same issue.
Exact same issue. Just stuck on connecting.
Yep, Ive tried restarting thinking maybe my router/modem !@#$ out on me. Still no luck. Internet works fine otherwise!
Having this issue too.
Just "Connecting".
Also a sticky in the tech support page is at 10 pages or so. So Im guessing we arent the only server.
Finally got through. Just sat at "Connecting" a while. Not sure if they fixed it or if it was just the slowest login ever. :)
Same here on Area 52, looks to be affecting multiple servers after they did the rolling restarts.
same thing here
whats up bliz ?
I just waited about 8-10 mins on "Connecting" and it let me log in. Just don't keep trying over and over, let it sit and it will let you in, I've seen this before when Cata was released.
Same here. I am stuck at the connecting screen as well. You'd think for 40 bux they would make sure crap worked more properly. :|
got in also after 10 minutes of connecting

Join the Conversation

Return to Forum