Upjade Complete!!! TIAN MONASTERY PROBLEM!

Bug Report
I've been through all of Jade Forest looking for a quest or something to lead me to finish the Tian monastery for credit for the [Upjade Complete!] quest but can't find any leads or connections, and I've found other people having the same problem.
Found my own solution! If you can't find anymore quests and you're positive you've done everything restart the game and you should get it when you log back into that character!
Had the same problem, just relogged - got the achievement.
Relogging worked for me, too.
Same here. Wasted like 30 minutes looking for a quest that was already complete.
I experienced the same problem.
Same. Relog and get achievement.

Please, fix this.
Same problem as all the others. Just relog and get your achievement!
I have scoured Tian Monastery, and the surrounding zones. No quests. Tried relogging. No avail.

/cry

*Edit. It worked when hearthed back to Org. Weird.
Confirmed: If you relog and it doesn't work, hearth. I hearthed to Dalaran, and got the achievement marker.

It doesn't pop up...it's just there in green where it wasn't before.
I relogged and hearthed, still didn't show up... keeping me from getting Upjade Complete, kind of disappointing.
Same here, reloaded and got the achievement
Just added this to the known issues list. Thanks for the reports!
Thanks. My friend had this problem the other day and we looked all over trying to figure it out, but never could. He just gave up. And today I was having that problem on my druid and this really helped :) Thanks again.
i trued doing this but didnt work for me and i hhave ran up and down the place but no qeast what should i do
The same thing has happened. I have reloaded, restarted, hearthstone to Org and nothing has fixed this problem for me.
Had the same problem since i dropped quests left zone then came back decided to complete did some quests the monastery one was missing for achieve i relogging and it worked.
I am having the same problem, and I tried all these things, and nothing is working. I even rebooted my computer. Hope this gets fixed soon.
Had the same problem...relogged did not work...hearthed to Org and that did the trick

Join the Conversation

Return to Forum