Freezing in Mogu'shan Palace

Technical Support
For some reason when I get to the final hallway going to the final boss room in Mogu'shan palace my wow will just freeze, when it does this I cant tab out or anything however I can still talk on vent and such.

Twice it has done this and twice its required a hard shutdown and restart to get back in... once back in the game runs fine.
This is exactly what is happening to me also..... Only that instance, only that area.

Have tried it with no addons, going to try dropping my vid settings way down, /hope

Any suggestions for other things I could do would be very appreciated.
Yeah no kidding, I don't want to have to hard shutdown to do the place and get kicked from a random.....
I will try running in windowed mode with everything turned down today if I get that place as a queue.

If it freezes at least I shouldnt have to hard shutdown my computer.
Has a solution been posted anywhere? I just started having this problem after today's maintenance. I queued twice, got Mogu'shan both times, and both times had the game freeze on the second floor. The second group didn't kick me right away, they let me get DC'd two more times before kicking me. Additionally, when I get kicked from there, it sends me to my hearth and not to the location I queued from.

Also, I noticed that if you hit the windows key, WoW doesn't minimize, but you can then ctrl/alt/delete, and get your task manager up. You can stop it from there without a hard restart.
I had the same issue on my holy pally tonight. No one else on the team had any issues. I had to do restart my system twice. I was able to get in when our priest life gripped me through the door. I have had no other issues in the past few days since the expansion with lag or freezing up.
Yeah I ran mogu'shan twice today in windowed mode and it froze once out of two.... right as we pulled the final boss
A guildie and myself are having the same issue as well only in Mogu Palace.

Still waiting for a solution
I'm having the exact same issue here. Only happens in this dungeon on both heroic and normal. My girlfriend isn't having the issue and she has the same video card as me gtx550 ti, and also a very similar computer to mine.
Same issues here. Any solutions blizz?
Same problem here, I usually crash at the second floor, but sometimes I freeze on other places.
It's been infuriating, everytime i enter that dungeon I get apprehensive, fearing that my wow will crash.
Also having this issue. I have to keep a another window of WoW open in the background so I can log back in as quickly as possible. Seems to be random but right near the last boss. :(
Yeah, just to repeat, I'm having the same issue, and only on Mogu'shan Palace. Both times, when I have logged back in, I haven't been able to talk in party chat, but guild chat is fine.

The first time I was in the halls up to the final boss, second time it happened right as we were heading to the elevator to go up.
Same issue here. happened on the last boss as well btw. I pulled him and immediately got frozen.
Same issue here also does anyone freeze or lag for around 15 to 20 secs when opening and looking at toons gear??
Yeah its gotten really bad I freeze every single time usually around the elevator.
Yeah I have had same issue at the start of the last Boss pull twice when I was the healer had full wow lockup yesterday and I thought it might not be as bad if I went in DPS for the group if it happened again. Well it happened 2/3's of the way through the boss kill came back dead after forcing wow to stop, updated vid drivers no help. Hope Maintenance fixes it somehow.
Same exact issue, same exact place. From the elevator shaft through the final boss. No add ons at all, not even any old folders in my directory. Ive deleted my cache WTF and add on folder just in case. It happens randomly, sometimes not at all and sometimes 2 or 3 times in a row.

I'm pretty sure it was happening prior to Fridays maintenance on normal and then after on heroic once i hit 90. First half of the dungeon no problem at all.

Ive reset my settings back to default via launcher also. Did a fresh driver install prior to mop ( nvidia 480 ). I cannot see it being on our side, but then again who knows.

Lets hope Tuesdays maintenance fixes it.

EDIT: It also seems to only be the client, alt tabbing allows me to open other programs up no problem. My task manager doesn't show anything unusual, resources are fine etc etc. Seems to be only WoW.
Just want to throw in that this happens to me as well.
Getting this issue also from the lift up until (and including) the last boss. Using the 64-bit client.

Join the Conversation

Return to Forum