Freezing in Mogu'shan Palace

Technical Support
Exactly the same issue I had also.
same here....really frustrating ...get nearly to last boss and need to do hard reboot...switch PC off and start again....then have to hearth to stormwind....talk about makin you angry
when r u going to fix this, its a nightmare running that instance, almost a guarantee 1-2 freeze per run, this really !@#$ up. On every server restart, i was hoping this bug get fixed, but u disappoint me every time i loggon & run this instance.

10/04/2012 08:11 PMPosted by Vanderharr
same here....really frustrating ...get nearly to last boss and need to do hard reboot...switch PC off and start again....then have to hearth to stormwind....talk about makin you angry

u dont need to off ur pc, just ctrl-alt-del call out task manager, terminate wow.
I'm having the same issue for the past 6 days now, I remember getting Mogu'Shan Palace as my random dungeon 5x straight and WoW froze in all of them right before or during the final boss.
Same issue. 64-bit client, NVidia Geforce GT430.
Happens to me too, and in general Mogu'shan Palace - my computer temperatures are at 50-60 degrees celsius. Running 64-bit client, going to try 32 bit client instead.
10/05/2012 08:27 PMPosted by Grevas
Same issue. 64-bit client, NVidia Geforce GT430.


yup same i'm using 64bit client too, it seems like a problem for 64bit client
Same issues, I tried turning all add-ons off and settings down, used compressed air to clean computer, did all kinds of maintenance... it's the game not my computer. I'll be happy to help Blizz figure this out, but it needs to be fixed ASAP. The last boss room is a no go, and if I got this as a random I think I'd just save myself the trouble and drop group immediately.
Blizz...add me to the list of users experiencing this and let us know what we can do to help you figure out what is going on. Thanks!
tried it......it hard freezes up.....non responsive from keyboard
and the elevator is annoying too, can't it just stop & wait for 1-2 sec?
Any update yet? Noticed no posts since beginning of October but I'm still having this problem. In addition to having problems with that hallway up to the last boss, I have noticed that my elevator is delayed behind everyone elses in my groups. I will see them get on it before it's ever there for me yet I can still get on it fine. They also jump off when my elevator has a little more to go to the top so they are all apparently riding an elevator which is out of sync with the elevator I see. I have been the only one crashing out of our regular group doing this and my husband has the same machine & using the same client as I am... odd & very, very, VERY frustrating! I shudder everytime that instance shows up now in queuing but we both still need gear from it... :(
Now already Nov, and the problem is still there.
Same issue. Has blizz acknowledged this bug anywhere?
OK I've tried to run mogushan palace on my friends PC, still freeze.
Below is the detail of both me & my friend's PC, hope this help.

My PC:
processor: i5-2500k
GPU: GTX 570
RAM: 4x4GB DDR3
mobo: Asrock z68 fatal1ty
Win 7 ultimate x64

my friends PC:
pentium duo-core E6300
GT 440
2x1GB DDR2
Asus P5KPL-AM
Win 7 ultimate x86
This has happened to me so many times on four toons I have lost count. I initially reported it to the Blizzard's Tech Support who then checked all my specs and suggested I get new drivers for my graphics. Which I already had but I did everything again as they suggested and still WoW freezes in this instance. They tried to tell me it's because the last boss is very graphic intensive. I don't see how riding an elevator or walking into a mob (much like any other mob in the instance) can be so intense.......

Plus, my game has no problems in 25man Raid Finder, Sha kill, nor any other instance. My guildies have experienced similar freezes and they are running machines far superior to mine. I reiterate that my WoW does not freeze up on any other instance or raid. Just this place and always between the elevator and the last boss, or on the boss itself.

The times I actually restart my computer, log in and come back (not get kicked), I can't use 'Party' chat at all - says I'm not in a party.

I don't think the tech staff at Blizzard actually know how to fix this. I have re-opened my ticket several times and it's the same response. Have you got latest drivers, download your specs so we can check again, clear out WDB and WTF folders......

The latest response from Blizzard is that this is due to 'data loss' because my Internet intermittently 'drops outs' according to what my the network diagnostic shows. They suggest I contact my ISP now and make sure my Net stops dropping out. If you can't play WoW because of Internet drop outs, I think that would rule out pretty much everybody in Australia......

I have to say, they do come up with some inventive explanations when they can't solve something just to buy some time.

Anyway, it's still not working and I wish someone would give us an answer and/or fix this. So many people have compliant and still no solution. I keep hoping the next maintenance will fix this but yet again it has not.

I've even reinstalled WoW and still has not gotten rid of this problem. Could this be some sort of virus? I never had trouble in the first couple of weeks of this expansion until one time someone froze while running in my dungeon group. Ever since then, I have had this problem.

I can't begin to count up how much lost Valor Points, tank bonuses, gear and XP my toons have missed out on due to this. Not to mention the number of times I've had to reboot my computer due to this. It's very frustrating. If I didn't get a dungeon deserter debuff, I would rather leave as soon as I enter this instance.....

Hopefully, one of these days Blizzard will admit they stuffed it and either get rid of the instance or implement a new one. Maybe in the next Expansion......
Been having this problem for months. I love how idiot pugs would respond with 'your computer sucks' when I told them my client might freeze/crash by the time we get to the upper floor. It could happen anytime between the elevator hitting the upper level to the last boss dropping loot, although the loot roll bug seems to be a separate glitch all its own which has been happening in all instances since last week's stealth patch.

I find the lack of a blue response disturbing.
The times I actually restart my computer, log in and come back (not get kicked), I can't use 'Party' chat at all - says I'm not in a party.


This bug has been around since Cata. Guess all the bug reports just went direct to the circular file.

I can't begin to count up how much lost Valor Points, tank bonuses, gear and XP my toons have missed out on due to this.


You probably should make a macro that inform the group about the bug and tell them you refuse to waste your time until it's fixed, then drop group. Yes it sucks for the dps who waited for the queue, but chances are they would be hit with the glitch and face the same loss of VP / wasted time as well. If everyone start to drop group when they get that hellhole, Blizz will eventually realize it's a serious enough problem and need to address it, kind of like how the mass group quits in Heroic Oculus forced them to take a second look at the instance and do something about it.
Having the same problem with freezing in Mogu'shan Vaults.

The game freezes during boss encounters for me. 1st, 2nd and last boss.
Everything goes well in the encounter and then immediately everything stops but the music keeps playing.

To eliminate any of the usual suspects from the troubleshooting section I completely formatted and reinstalled windows 7, installed all updates and drivers and upgraded video drivers to the most current ones available from manufacturers website. Also upgraded directx. I then installed a brand new fresh copy of wow onto my computer and allowed that to be fully upgraded before playing. I then played wow with no addons installed.

Got the same freeze on the first fight in looking for raid with the protectors at 30%.

Talked to a few people at work and found that one of them was having exactly the same issue as me so I know its not just my computer.

My computer has never frozen or crashed.....ever....while playing WOW. And it does not crash anywhere else in the game regardless of amount of time played.

I play plenty of other high end games on this PC and have never experienced any problems with them as well so I doubt its hardware related with my PC.

Basic specs:

Intel Quad Q9400
8gb Memory
Win 7 ultimate 64
Nvidia GeForce GTX 460
This happened to me twice today, I haven't done a dungeon in awhile.

Operating System
MS Windows 7 Ultimate 64-bit SP1
CPU
Intel Core i7 2600 @ 3.40GHz 43 °C
Sandy Bridge 32nm Technology
RAM
12.0 GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)
Motherboard
Dell Inc. 0Y2MRG (CPU 1) 37 °C
Graphics
SAMSUNG (1280x1024@60Hz)
AMD RADEON HD 6670 (Dell) 55 °C
Hard Drives
1863GB Seagate ST2000DM001-9YN164 (SATA) 39 °C
Optical Drives
PLDS DVD+-RW DH-16ABS
Audio
Realtek High Definition Audio

Join the Conversation

Return to Forum