[BUG] Mage Frost Bomb

Bug Report
Please for the love of all things holy fix the frost bomb bug that causes a sound loop which is extremely annoying. I have had to play with the sound off since the 5.0 patch and it sucks, I want to be able to listen to the sounds of the game and not get stuck with the most irritating sound loop ever every time I use frost bomb.

The only fix is to turn the sound off (which is what I had to do) or to check and uncheck sound reverb, headphone, some others might work but those fix it for me, but I am not going to do that after every fight to try to play with the sound enabled.... Please fix, this has been a known issue since beta.
I have been having the same problem and it is driving me crazy. I enjoy playing with sound on, which forces me to close and reopen the game any time this sound gets stuck. I know there is a way to remove the sound file from my game but I would prefer to only do this as a last resort. The looping does seem to cause lag as well as being irritating so the sooner fixed, the better.
Agreed very annoying!
^
^^^^
I was hopeful this would have been addressed in the last patch (5.0.5) but nothing.
^
At first I thought it was a problem with the water elemental; then I realized it's Frost Bomb.

WTB fix, please.
This also occurs with Arcane Explosion :(

Changing your sound settings to disable DK Voices then Re-Enable them will cut the effect until it occurs again.
Thank God I'm not the only experiencing this sound loop. It's driving me absolutely nuts.
I'd like to use frost bomb, but i am speccing out of it because of this bug......

Join the Conversation

Return to Forum