Temp fix for Water Elemental casting sound.

Mage
10/03/2012 08:40 PMPosted by Fireinice
im fire and just started getting the problem today. between lvls 75 to 78 (current). not sure if maybe frost bomb is the cause or maybe combustion? just thinking if new spell i got is what causes me to start getting this as fire spec


What bomb are you using? So far from what I've read, it seems as if all the bomb spells might be having this issue. I'm wondering if people are already working on it.
Sounds like that seems to be the problem. All three specs are saying they have the problem. I don't know what sounds the others use, but the water elemental cast is the same as the frost bomb cast. This is definitely looking like a bomb sound issue.

I hope this gets looked at soon. In the meantime, if anyone finds out anything else, please keep posting it here. Thanks for all the feedback thus far.
Areswarlord,
I'm using frost bomb
Same issue here too. I grabbed the addon, that got rid of the WE's gurgling sound (which was nice), but I still have the issue where it sounds like I get suck with the casting sound from summoning him.

Oddly though, doing a /reload ui doesn't help for me, but either checking or unchecking the DK voices does fix it - at least for a few minutes. :P
This is incredibly annoying and seems to happen every 10m.
This happens to me in any spec. It gets even worse when I'm using NT.. It gets really loud, like there's 4+ of the sound playing at the same time. Sometimes it gets so loud I have to take out my earphones.

While I'm here: the Water Elemental sound he makes is driving me nuts, too. It's another sound, one that all Water Elementals make by just being next to you. Do you guys know what file to replace for that one?

Edit:

I currently use
http://www.curse.com/addons/wow/waterelementalmage-sound-remover

You have to install it perfectly in order for it to work, but once you get it working you wont have to deal with that sound anymore!


I guess I should've read all the posts. I'll try this one, thanks.
This happens to me in any spec. It gets even worse when I'm using NT.. It gets really loud, like there's 4+ of the sound playing at the same time. Sometimes it gets so loud I have to take out my earphones.

While I'm here: the Water Elemental sound he makes is driving me nuts, too. It's another sound, one that all Water Elementals make by just being next to you. Do you guys know what file to replace for that one?

Edit:

I currently use
http://www.curse.com/addons/wow/waterelementalmage-sound-remover

You have to install it perfectly in order for it to work, but once you get it working you wont have to deal with that sound anymore!


I guess I should've read all the posts. I'll try this one, thanks.


You don't need the add-on. Just under the same Sound folder referenced earlier in this thread, make a folder called Creature, and under that folder make another folder called WaterElemental (no space between words). Then put another of the blank .ogg files in that folder and call it "WaterElementalLoop.ogg" and you'll be good.

So by default on Windows 7, the entire path would be: C:\Users\Public\Games\World of Warcraft\Data\Sound\Creature\WaterElemental\WaterElementalLoop.ogg
Incredible that this problem has been known since 2012 and it is STILL not fixed.

Nice job, Blizzard.
For me it isn't just the elemental. When I'm partying with my brother, his priest spells keep getting stuck. If i run far enough away that it unloads his character it goes away. But re summoning the elemental works for me, too.
Its an old bug that seems to have come back. I'm sure it will get squashed again at some point in the near future.

Join the Conversation

Return to Forum