account issuse

Customer Support
As you can see im logged in on this account.. I can surf the blizz site but it will not let me go into my account settings to accept my scroll of rez... the page will not load all it says is problem loading page and then this The page isn't redirecting properly







Firefox has detected that the server is redirecting the request for this address in a way that will never complete.





This problem can sometimes be caused by disabling or refusing to accept
cookies.

I have tried this on 2 different computers an on 3 different browser help... What can i do
please someone help!
I have went in an deleted all my cookies for this site fixed it to where they are not blocked and still the same error is popping up.. I do not want to have to create a new account because i want to use the benefits from the Scroll and help a friend out.. But if i cannot get past the main site into the account part to even accept or turn on my account i cant even play!

I can't even click to get the digital version of MoP... Same error is popping up :(
There isnt anyone that has EVER had this problem??? please help
Does this happen with any other webbrowser such as Google Chrome or Internet Explorer?
yes that is the 3 browsers ive used an all 3 give me a error

I also done this on another computer at my friends house an we still get this error but if she logs into her account everything is fine
Power cycle your Modem and Router. Unplug both for about 30 seconds. Plug the Modem back in, wait for for it to finish coming up then plug the Router back in.
Retry access to account management
Also with useing internet explorer it just tells me that it cannot display this page
You should be able to log on to account management and claim it via the Scroll of Resurrection page, Savvy.
I have the same issue... Did this ever get resolved?

Join the Conversation

Return to Forum