Tian Monastery bugged?

Bug Report
I did every quest I could find relating to the tian monastery, the last one was for the waxwood tigers quest and upon completion i got the banquet scene at the banquet grounds, got drunk, passed out on the floor. Woke up and didnt have the achievement or the blue quest reward it says should be there from wowpedia.

Is this a bug?
Have you finished the zone yet? Cause I got Upjade Complete when I finished the last questline even though I didn't get the toast window for completing Tian Monastery.
I'm having a hard time completing this myself. I don't have a single quest left in the zone, I've got all the other requirements for "Upjade Complete" done, yet it tells me I don't have "Tiam Monastery" done yet. I fly back over here, and there isn't a single quest giver for me to talk to!
I'm going to add myself to this, I just completed the final quest (the second banquet after beating rumpus), the Elder said he had something for me after the banquet and when the blackout lifted... nothing. No quests, no achievement, no items.
any solution yet?
Same problem here.
Also having this problem
Having the same problem as well.
same here !
me and another guildy are having the exact same issue with Tian Monastery not showing up as completed
I too, am having this issue. I've verified that I've completed all the quests...I'm even using the shield from the final turn in. Is there a hidden quest here?!
I had that issue as well and i decided to go to org(hearthstone) and it said i completed it when i got there
Add another one. I also didn't get my weapon that Wu crafted for me.
09/25/2012 06:41 PMPosted by Dawnoflight
I had that issue as well and i decided to go to org(hearthstone) and it said i completed it when i got there


This worked for me.
The quest is bugged. I saw a post that requested you relog. worked for me.
Just exit out of the game and Log back on, you will get it the second you come back on. It worked for me.
Tried to relog, tried hearthstone to orgrimmar, negative results.

I dont have anymore quests to complete there as well, still havent got the step in green
Relogging worked for me. Thanks.
I relogged and that worked for me as well.

Join the Conversation

Return to Forum