[Bug] Masterwork Spiritblade Decimator

Bug Report
Just made this weapon and it is not showing up while sheathed. Thought maybe it was just me and tried relogging etc and still the same thing.
Noticed this as well. I can see it in the occasional zone or dungeon, but it's invisible 90% of the time.
Yeah I just made one too and it's not showing on my back either. :(
Same issue for me. I could see the weapon I had on before I made this one, and my fishing poles show up, but not the axe.
I'm getting the same problem. Not showing on on my back, but is fine in hand.
Tauren warrior with Titan's Grip.
Other weapon is showing up fine both in hand and on back.
same problem here
I got two on and can't see either one on my back. Definite bug... although I guess I can sneak up on stuff and make it think I'm unarmed...
I just had one made today, am I'm to am getting 2 of these made. So now it looks like I have no weapons equipped. Wtf? Please tell me this is a bug.
Ill bump this up and say it happens to me too. Also i dont know if you orcs are benefit'ing from the Axe spec racial when using this weapon but i dont.
Same thing is happening to me. Old weapons showed up fine fishing pole shows up as well. I made myself two of these useing up just about all of my spirits of harmony I might add. I equip them, and then nothing grrrrrrr. Lets go Bliz fix it up please and thank you.
Yeah not showing on my back ether, pretty annoying

Join the Conversation

Return to Forum