Pets do not show up on armory website

Website Bug Report
Prev 1 2 3 4 6 Next
ya, I have logged into all my toons and it still does not work for me.
Gilroykilroy said:
Perhaps the age of the accounts is a common denominator in those accounts that fail vs those that work?

I was actually wondering if it might be something like that. I've had my main account since about 30 days after the game released. I now have 4 accounts all tied to my battle tag, 3 of which are active.
Paratryn, thank you for the updates. Despite not being able to see my pets in the armory, i still love the compainions and have pretty much just stuck with using a manual update for my warcraftpets account.

I am having a real blast searching for all the new little critters and know that eventually you all will find the bug.

I too thought maybe it was something to do with my account. I had an active account for many years but took a break last year for personal reasons. I reactivated my account right before the launch so, I figure that could be an issue.

Anyway, great job on the pet stuff and everything else. I had almost forgotten how much i love my toon and her little pets. :)
I just discovered this thread. I am also affected. I also have a vanilla account, from May 2005.

I also moved this toon from my original server (Kilrogg) to Proudmoore in November 2011, if that helps at all.
Just adding that pets are still not showing up on my armory, though mounts are showing fine.

It's also constantly showing that I've "Completed step Obtain 100 mounts of achievement Mountain o' Mounts. X hours ago" in my recent activity feed.
Now that you mention it Syrrie, I noticed today that the It's Over 9000 achievement is starting to repeat in my armory activity feed.
pets dont work for me either, they never show up.
I too can not see my pets in the armory, and my account is also pretty old. (11/2005) Glad I could be of service.
It still hasn't updated my pets in the armory. Its been nearly 2 weeks and it still shows nothing
Having the same technical difficulty.
Remember back in the day when there wasn't a pet window? you had to keep all your pets in your inventory. Well I had a few of those on a character of mine, pre Burning Crusade that I attempted to sell in the auction house and could not due to some bug.

When you made the pets account wide, I went ahead and learned these pets, which may have broken your code some how. My emerald whelp was one of these such pets.
This is giving me a case of the sads. None of my characters show my pets. Old account, if that matters.
Sorta the same as Lazerus. I had a few extra unused mini pets and mounts that the game had sent me when I faction changed a few times just sitting in my bank. My character had already learned them, but I was hanging onto them, just in case they ever because un-soulbound. I destroyed them a few days ago for bag space.
Same story for me, no pets showing in the armory at all. :(
Relatively new account here, roughly 18 months old.
I went through my pet journal yesterday and cleared out all my duplicates, so there has been a flurry of activity with my pets, but still no changes on the website.

If it helps, my pet achievements are really odd as well. I'm still seeing all the individual steps of "Taming of Kalimdor" even though I have got the achievement. Normally once you have got the achievement the individual steps disappeared from your activity log.
Having the same issue as well. Just adding a post for reference.
10/04/2012 08:12 AMPosted by Gilroykilroy
For the problem of pets not loading at all, we do people looking at it. For some accounts (we haven't found the bug yet, so we don't know what about the accounts is causing this) account wide data is not loading for the website. I don't have a good ETA on a fix but it's not anything you guys are doing in game.

Perhaps the age of the accounts is a common denominator in those accounts that fail vs those that work?

My account is a Day 1 account so presumably it has been migrated over to different database formats over the years (like merge, etc.) Perhaps during one of those merges some fields were left uninitialized and contain random data that is affecting display of pets?

Interesting theory. My account is also a Day 1 account.
My account doesn't show my current battle pet team, but it does show a MASSIVE list of duplicate heavy companions, some of which I only have one of in the game (Darkmoon monkey is an example). It shows some of them named, some of them not (all 320 of my current pets are named) and it shows my main three (Fox kit Tod, Celestial Dragon Faythe [whose name is now Christle], and Guardian Cub Valistah) still at level 5 when they are all level 20.

Could addons that modify the pet journal be to blame? I'll uninstall mine tonight and check. Will edit with an update later.

For those of you with the age theory: My account is 10/26/2010 and has issues with the displays.
I too have this issue.

- No pets showing up on the armory page.
- Earned pet achievements show up fine.
- In progress Pet achievements do not show progress -- eg "Going to need more Leashes".

- I've had this account since early-mid BC.
- I've got multiple wow accounts tied to the one account.
- I've collected multiples of the same pets across multiple toons, and thus have more than three of some types (eg -- the christmas pets, I think I have ~ 7 of the snowman)
- I've got old account bound pets still in my banks on several characters (eg the collector's edition pets, the blizzard bear, etc)
- I've moved this toon multiple times across servers.
- I've faction changed once.
Likewise not showing my pets, and likewise have a vanilla acct (around 11/04 if I recall correctly). Hope posting helps towards finding the issue, since this seems to be a common denominator of at least a few of us posting here. =)

p.s. =( Am not lonely. Even when my in-game friends are being poo-poo heads, I still have Sniffles, Elliott, Dinner, Cuddles, Snuggles, and Sleepy to follow me around.

Join the Conversation

Return to Forum