Pets do not show up on armory website

Website Bug Report
Prev 1 4 5 6
I am also having this problem. No pets show up. I have logged on and off my characters several times.
10/16/2012 04:14 PMPosted by Peratryn
We found the main issue here and fixed it. At this point we think that pets (and some account wide achievements) should update for everyone once you log out of all characters. Much like how character profiles update when you log out, account data updates when you log out of all characters. If anyone still has no pets showing up after logging completely out of all clients please let us know and we'll look into it.


I really appreciate the update and concern, but its been nearly a month and still nothing has changed for me. Ive tried everything, but it still shows no pets on my armory.
I'm collecting all of the users that are still experiencing this bug so we can track down why, it definitely appears that the recent fix wasn't the only issue at play.
Those of you that have responded since my first fix notice, can you trying logging out again and letting me know. I think I found the server issue causing your accounts to not update.

Again, please post if your pets are still not loading and will continue to try and find any issues that still exist.
I have been using this toon, 90 percent of the time, and i log out every time and exit the game. I have been trying to view my pets online for almost 2 weeks, and it still shows nothing. I think i am up to 130 unique pets or so. Thanks in advance for your help.
I've collected over 150 pet and i'm having the same problem as rest. Thanks for your help.
Yes! It finally shows! Thanks.
Yoeleven: Your pets have updated since you've posted.

Rhyn: You should have been affected by the same issue that was fixed yesterday (also affecting Honeypot and Yoeleven), if your pets don't update when you log out later today let me know.
My pets aren't updating :(
10/25/2012 09:17 AMPosted by Pebble
My pets aren't updating :(


Can you explain your problem in more detail? This thread was originally about pet who had an empty pets page (pets weren't loading at all). It appears that yours are.

Are your pets just not updating (levels and stats) the way you expect? Remember that you must fully log out of your wow account (all the way to the login screen) for the update to occur, and even then it can lag behind (much like character profiles). If you are logged into wow from multiple places you need to log out of all of them.
10/25/2012 09:27 AMPosted by Peratryn
My pets aren't updating :(


Can you explain your problem in more detail? This thread was originally about pet who had an empty pets page (pets weren't loading at all). It appears that yours are.

Are your pets just not updating (levels and stats) the way you expect? Remember that you must fully log out of your wow account (all the way to the login screen) for the update to occur, and even then it can lag behind (much like character profiles). If you are logged into wow from multiple places you need to log out of all of them.


My armory is showing my pets from like a week ago; new captured pets aren't displayed, levels aren't updating, etc. Not logged in anywhere else, and of course have logged out in that time period (Of everything).
I am having similar issues to Pebble. My pets show at level 21-17 for the ones I use primarily. They are almost all 25 now (I think 2 25s and a 23). I have also caught around another 100 pets but am not being shown as having many of the Outland and Mists pets I have collected.

I do show the achievements I have earned since then (Outland Safari, Outland Tamer) and equipment I've looted, but the pets (both collected and levels) do not appear to be updating on the site.
My pet section of the armoury is not updating. It's been about 17 hours and always takes a day or so before it does anything if I am lucky. It still says I have the same three pets in my party that I had yesterday and not my current ones. I've tried everything to make it reload to my current ones so I can keep track of my pet score on Wow progress. ;[
This may be on another type of subject, but along the lines of the Battle pet thing as well as just normal pets thing, if you happen to put a caged pet on the AH, seems that they do not show up on the AH from the remote website, or in any of your inventory on the remote site, like I currently have I believe 3-4 Battle pets on the AH atm, but on the remote site they are not on there under items selling, nor can you even access the Battle Pets section for purchase, is this strictly an in-game type of thing like you cannot buy or sell battle pets through the remote site?
My pets have disappeared from the armory pages completely. They were working fine until a few days ago.

It's showing that I only have one slot open with no pets. It looks like I haven't ever done a pet battle when in fact all three slots should be open and filled with pets.
Ok, so still trying to figure out why Battle Pets are not visible on the Remote AH, but pets that have not been used as Battle pets do show up, is there a break down in the line of code that hinders the Battle Pets to be able to be viewed on the remote site?, if so is there any possible way we can get a Blue response letting us know that the Battle Pets thing is being looked into?, Like for instance there is a Battle Pets tab on the remote AH but every time you try to search for a Battle Pet to buy, it says no results, but I happen to know there are quite a few for sale in-game, I myself have a few for sell, but cannot view them on the remote site........I'll tell ya what, I'm going to twiddle my thumbs and then go play a solo game of chess, just let me know when we can look into this............................
My recent mounts are not showing up on armory either. I've logged out completely and checked armory and still nothing. Can you please post a solution?

Join the Conversation

Return to Forum