Hostile skies wow quest is glitched

Bug Report
Hostile skies wow quest is glitched for me.

Where you are suppose to shoot down 50 Kor'thik Swarmers.

When I jump on the cannon to shoot them down, there is no up/down button just left and right... I have tried EVERYTHING to make it go up/down and as this is vital to the quest makes it very frustrating..

HELP!?
this IS a MOP quest btw
i'm having the same issues.
Right click to move around including up and down. Just figured it out.
Maybe because I have Mac OS X (?) this still doesn't work. Can only move right or left. P.S. (I don't have a mouse for that solution, either.)
OK, I put out a ticket and this is how they told me to do it with no mouse. Just right click and drag cannon towards target on track pad. Worked pretty good, anyway finished quest.
They really need to do something about this, I struggled with the thing for quite a while before I found this thread. It needs to be made obvious how to aim the gun
wtf this sucks!!!

Join the Conversation

Return to Forum