Patch 5.0 & MOP created bad fps & stutter

Technical Support
Prev 1 3 4 5 22 Next
/signed. I get into a dungeon and it's frame rate/lag spike central. I've stopped doing 5 mans and don't see myself raiding until this is resolved. Massive anti-climax for an xpac.
I had to do this for GW2 and just tried it now. It seemed to work.

Change you type of display mode (Graphics > Display Mode) to either windowed (fullscreen) or just windowed.

I went from 32 frames back up to my normal 70-150 frames in Panda land.

Hope this works for you!
Well changing my mode to Full screen (Windowed) worked to fix my frame rate. It now varies between 30-90 FPS. But my systems now hard crashing after a few minutes.

After an investigation inside my box and testing with WoW i have found that these hard crashes are caused by Thermal events that only occur while World of Warcraft is running. To top it off, My Video card is now cooked and useless. Now not only can i not play WoW, but i cant play other games either. Im stuck using the motherboards on board just to browse the internet, what a waste of a $2500 machine.
The shop that built the machine say they cant replace the card and they cant upgrade it without destroying the power supply, and upgrading the power supply will overload my motherboard so essentially i need a whole new computer!

Thanks Blizzard. Thanks alot!
Bumping and updating original post to reflect recent additions to the situation.
This is silly. My framerate dropped considerable after 5.0 dropped and my graphics stutter all the time MoP zones.
10/03/2012 09:31 AMPosted by Arkticsizzle
Bumping and updating original post to reflect recent additions to the situation.

To Arkticsizzle, Oneball, and everybody,

Just a quick udpate here.

I just downloaded the 12.9 CAP from AMD's website, which was supposed to resolve some graphics issues with WoW.

Just playtested, and the 12.9 CAP didn't seem to make any difference. The stutter is still there.

I still have everything set as before. Multisampling at 1x, AA at 4x, Overall Graphics settings set to the recommended levels, mostly Good to High, with Shadows and Sunshafts Set to Low. Vertical Sync, Reduce Input Lag, and Triple Buffering are all ENABLED. I have Max Foreground and Max Background FPS Sliders set right to the middle of the slider bar. I am running in 32 Bit Mode. And I am still reverted back to DX 9.

One note, I do not recall if I have ever playtested the game in Windowed Mode vs. Full Screen Mode, or Windowed Full Screen Mode. I will try all of those today and see if that might make a difference.

Also, a revision to my original description of my "stutter". I am not so sure now that I would classify it as a stutter any more. From what I am hearing other players seems that my problem is more of an intermittent "JERK", and it's not consistent, it doesn't happen all the time. It's almost halfway between an on-screen "JERK" and a frozen, split-second "FLICKER".....if that makes sense.

And, what's stranger, is that I do NOT have any FPS issues, I'm getting a solid 60 FPS with my ATI HD 5870 set to stock settings and with all my WoW Graphics settings set as described above.

That's the most bizarre aspect of this - I have NOT experienced ANY of the massive frame rates drops that so many players have experienced, and I have not experienced any spikes or plummets in frame rates. I've been holding at very normal 60 FPS, with the usual drops that are expected in large raids, crowded cities, etc.

So, it's essentially an inconsistent screen "jerk" that happens when I'm moving, but the whole time it's happening, my FPS stays consistently high at 60 FPS. And I'll get a few seconds of smooth scrolling of the terrain, and then suddenly the "JERK" to the whole environment. Also, I'll get in flight inconsistent animation, it will be smooth for a few seconds, then "JERK" to catch up.

Also.....sometimes in certain areas, I'll get the stutter/jerk in one spot, but then I'll go back and run right past the same area, and it DOESN'T happen.

I just tried that near the entrance to Ironforge. I ran past one of the big stone wall structures near the front door, and I got a few seconds of stutter/jerk, "cheesegrater" effect......then ran back and forth again, and it did not happen.

So, to sum up, I don't so much have a constant stutter, but more of an inconsistent screen JERK or TWITCH like the whole screen micro-freezes for a SPLIT second, then I get a few frames of smooth scrolling animation, the the whole surrounding environment JERKS again.

Just wanted to be as specific as I could with my description, since we're all experiencing different things that could have common themes running through them.

Day 34 of this......I just want to play WoW again. The Thousand Yard Stare is setting in.

Going to get more coffee lol........
I have a random stutter, I call it random, as meaning, it comes when it wants to. By in large, it is always happening at some point. My fps drop, just amazing at how bad it is. I recently tried windowed mode(s), mouse scroll to lowest speed, already had the caty control center wow profile installed, and I just keep mixing and matching settings, to no positive results at all. On occasion it looks like its going to be normal, but 1min later, boom, its back to herky jerky fps drop. So far still, my most playable settings seem to be this:

the rest good, with multisampling at 1x

I do have vsync on, as well as 3x buffering and reduced input lag and mouse wheel set to lowest. And the fps limits set to 60 on foreground and background.

i5-2500 quad, 8gigz ram, radeon 6850 1920x1080 dx11 64bit

It results in a horrible looking game at 40-55fps that by all accounts is not fun to play. It is the only way to play at it at the moment while keeping my video card fans stable as well. And just like most of you, I have tried everything imaginable. This is so demoralizing.

Blizzard, amd, idk, but I can play any game I have just fine on high/ultra settings, except for this one, which was fine pre-patch. I did think they would silently look in to it. But at this point, this long, without any sort of re-assuring response or acknowledgement, I'm not so sure.
Same issue as everyone else. Running i5 2500k, crossfire radeon 6870's, 8g of ram. Could run on max settings before with 60 fps. Now my fps is anywhere between 15-35 with stutters sometimes when I turn my camera. Runs every other game on max settings and can't run WoW = something's gotta be messed up on Blizzard's side.
...I would also like to add, that trying to play WoW for the past four weeks, while trying to stare at a fantasy environment that jerks every three seconds, I've developed my own head twitch to coincide with it -

Lots and lots of aspirin, and lots and lots of coffee :P

Sorry guys, I don't mean to make light of this at ALL, but if I don't have some humor about this, I'm just going to lose it. This is just beyond frustrating at this point, it's just ridiculously infuriating.

I love this game, I've been playing for three years, and this is the first Update I've ever seen that has caused so much chaos, and that has caused so many problems that couldn't be fixed.

It's just really discouraging.
I'm having FR issues just like everyone else, though I notice that if my View Distance is set to Low, my frames stay pretty high 70-150 but the moment it leaves "Low" to any other setting it goes right to 35 fps. I usually run on Ultra settings. I know its not that bad sounding compared to what I've read here, but it all did occur after the 5.0 patch. I've talked to so many GMs but they all never answer my question as to why it start after the patches.

Hopefully they admit to their mistake soon and provide a fix : /
I am having the same problem!! Why do they not have a fix or at least a reply to this yet?

Like everyone else I was running the game at max setting and now I skip around. FPS are still around 60 and do not go up or down. World and local both stay under 40.

It's painful to attempt to play the game at all now. I can't do dungeons, I can barely quest, raids are out of the question.

My fps averages about 20 where it used to average 30-40 in Cataclysm. When I turn everything low I still get the frequent "jerk" or "stutter", like time has become treacle gravy and is lagging behind as the world tries to catch up. It's downright annoying, and is rapidly making the game a chore as well as souring my experience with Mists.

The only thing I've found to help a little bit thus far is 2 macros I enable every time I login:

/console overridefarclip 1
/console farclip 10
/console horizonfarclip 10
/console groundEffectFade 10
/console groundEffectDist 20
/console groundEffectDensity 25

/console detailDoodadAlpha 10
/console characterAmbient 0
/console SkyCloudLOD 0
/console SpellEffectLevel 1

then the old /console gxRestart

For the most part though, the "screen jerk" is still present. Also, this will make the game resemble Team Fortress on low, with plenty of "mists" to fit the expansions namesake.
Same thing happenin to me, been tryin to play, tryin different fixes, nothin works. Maybe throw us loyal players some free gold or better yet help fix the problem.
10/03/2012 03:58 PMPosted by Halnta
Maybe throw us loyal players some free gold

Ha! Good one.
I also /sign. I finally got up enough money to buy the expansion and i can't play it due to the stutter(my eyes just can't take it), and i got my fps up to a whopping 20. Even in the game Rift (which is very graphics demanding on your gpu) I get 30 fps on ultra! So i just threw 40 bucks into the toilet so to say:(
/sign as well. posted a thread a bit ago about my issues before i saw this one. my fps seems to be normal my issues come from randomly and suddenly losing basically my graphics. my whole screen doesnt go black but the HUD disappears or randomly all NPCs are gone and mobs are attacking but can't be seen, and then issues where the world map comes up black and only trhe icons are showing. plus then I try changing zones or going into dungeons and the game will freeze on the loading screen and it forcesd me to close it and restart it. Let's hope Blizz takes this all into consideration because the game is slowly becoming unplayable.

This issue is occurring on all Mac platforms as well. On my laptop I've dive-bombed from about 80fps to 11fps. On my PC with even better hardware, I've dropped from about 70fps to 11fps.

I've played since the beginning.

Blizzard - you don't have an excuse!!
I'll sign this as well. This is a serious issue that we need resolved. i used to run wow at ultra settings and get around 50-60 fps , now my fps spikes below 10 and in combat/movement its around 8-10 this is horrible. ive done as much troubleshooting as i possibly can and still no results.
Ive been having the same issues with no resolve on the general troubleshooting. please blizzard see what you can do to fix this. i used to run on ultra with 60+ fps now i have to play on lowest settings but still get low frames. this is horrrible.

Join the Conversation

Return to Forum