Why cant I use the Questhelper addon anymore?

Oceanic General Discussion
I have a few unfinished quests in 2 areas that I can't find, and I'm really after the loremaster achievement. So I started using questhelper, and it was ok for awhile. But ever since Mists of Pandaria came out it said that the version was outdated, and it wouldn't let me use it!

My version is

Does anyone know what to I can do so it works again?
I stopped using QuestHelper a looooong time ago because it was just too unreliable and buggy.

Might I suggest trying the Moncai Quest Tracker? I personally love it.

It should be free to download and use via CurseClient - but if Curse flashes warnings at you about paying for a premium membership, don't be conned - just ignore it and download the apps you want.
wowhead.com type in the quest, wowhead shows the start finish points and areas...usually.

I stopped using questhelper years ago
You're running an old version. Each update of WoW tends to break all the addons which have a version check and won't work with a new version. Go to Curse and grab the new version (which is 5.0.5) Or because I was just there http://www.curse.com/addons/wow/quest-helper
Yea as Anthioc said you need v5.0.5.262r now.
I personally use WoW Pro's Questing addon.
I've just tried all the addons and they all kept giving bugs and crashing.

I tried Questhelper, Moncai Quest Tracker, and WoW Pro's Questing.
It's okay now. I've dowloaded an addon called QuestHubber and pointing out all the quests I've missed. It's great!

Anyway, thank you Mørganá and everyone else who offered advice in their replies.
When I was originally doing my loremaster chevo on the EU servers I used various quest finders including Questhelper- when Cata came out I was given the name of a quest finder I now can't live without http://www.curse.com/addons/wow/quest_completist it's really easy to use and is supports 5.0.5 :)

Join the Conversation

Return to Forum