Cannot plant seeds on farm, 'Invalid Target'

Bug Report
it's still not fixed. my druid's been bugged since the day the world server crashed. too much to hope for that they'll give us a few stacks of vegetables to compensate... /sigh. i too am on my second ticket regarding this.
I'm on my 6th ticket for this...
I just want to throw this out there, cause I thought I was having the same problem. Are you guys targeting the Tilled Soil when you try to plant the seeds? Cause, you need to if you aren't.
well, yeah. it works just fine on all the toons that i wasn't logged in on when the world server crashed. :P something got corrupted somewhere.
10/11/2012 02:28 AMPosted by Trixsta
I just want to throw this out there, cause I thought I was having the same problem. Are you guys targeting the Tilled Soil when you try to plant the seeds? Cause, you need to if you aren't.

Yes, the problem being described on this forum is receiving an "Invalid Target" error when TARGETING the soil and right clicking on a seed to try and plant it. I know there are several people on this forum that have described this issue. It is not a personal computer issue, it is not a cache issue, and it is not human error. This problem was caused by being in your tilling area when the world server crashed.

Anyway, it's still not working for me either. Here's the response I got from my 3rd ticket, not that it's very helpful or informative.


We are still investigating the cause of this issue, and unfortunately have no updates at this time. I do apologize that we don't have any more info for you, but we are looking into the matter for you, and hopefully a resolution will come soon. We appreciate your patience in the meantime.

If you need anything else, just submit another help request the next time you are online. We hope you continue to enjoy your experience in World of Warcraft!

For any game play questions, please refer to our site at


Game Master Kenshalus
Submitted another ticket today. Still no estimated time of fixing the issue. But the GM did tell me something interested. He said that we shouldn't expect to see a blue post in response to the issue. The bug report forums are more for them to just monitor issues and they don't usually reply.

Well I hope they see this forum and can consider giving everyone a few stacks of vegetables.
Happening to me as well, getting pissed off about it. Blizz has millions. Fix it. If they cant, bring in someone who can and spend some of that money.
Just hit Revered with the Tillers today, and had the wagon cleared to bring my total plots from 8 to 12, and again the new 4 are behaving just as the other Untilled Soils, and failing to become Tilled Soils when cleared.
It's fixed for me, logged on went to the farmland & all 8 were untilled. Tilled 1 planted the scalions & it worked.
Also fixed for me today!
Yep, we've applied a fix. If you're still running into this issue please respond.
Alright maybe I'm really stupid but...

I also had this issue, getting '' Invalid Target '' when I was trying to plant my seeds UNTIL I figured I had to target the soil.... Then it worked perfectly. Hope this help haha.
Minor issue related to the original bug. As it broke while I was doing the scallion quest & fixed after I had gotten the scallion seeds. Merchant Greenfield has a quest bubble on him that wont go away. The white bubble that means I am supposed to talk to him, I click on him but he has nothing to say it goes straight to the buy seeds menu. I think he is mad at me, my wife used to do the same thing until she figured out I prefer she not speak then she changed tactics.
worked for me! watering the tilled soil got the seeds to take. thanks for posting this!
I see posts saying that this is fixed, but my problem remains. The two rightmost soil patches have always worked as intended. But all other soil patches (I currently have 12) have despawned every time I try to till them. So I effectively only have 2 patches. I've been reporting this bug for over a month now and see the above blue post that the problem is fixed, but my problem most certainly is not fixed.

It really sucks having a completely gimped farm in this highly mats-heavy xpac.
Bump. I am still having this problem. The rightmost two soil patches have worked fine from day 1. All other soil patches despawn when I till them. As I increase rep and get more soil patches they all have the same problem.

I also have the talk bubble over the seed vendor's head but when I right click him it goes straight to buying seeds, no option to talk. I don't know if this is related.

I can't believe that I've been stuck with 2 soil patches this long into such a materials-intensive patch. This seriously stinks. And now Blizz says they have applied a fix on October 23 and yet nothing has changed for me.
Target the soil, then plant the seeds. I don't get the invalid target anymore.
Unfortunately your response shows that you don't understand what I'm saying (or more likely that you didn't even read it clearly.

It's not an invalid target problem. The problem is that whenever I till the soil, the entire patch disappears. There is no longer anything to target. This happens for all but 2 patches, much like others have described.

Join the Conversation

Return to Forum