[Bug] Quest: Killing the Quilen

Bug Report
Prev 1 3 4 5 6 Next
Also have this issue. After picking up the quest the first time and moving down, everything seemed fine, was able to get to 3/9 and then my dungeon queue popped. Joined that, when I left I was unable to continue on that quest no matter what I tried, did all the obvious things to try 'reset my phase' but nothing has proved useful as of yet.
Also having this issued, i tried to hearth out of the zone, and come back and pick the quests back up. Still nothing, seems like im phased.
Me too, I'll wait and see if today's rolling restarts remedy the issue.
I am having the same issue. Last night I was doing this quest, had my LFG pop, and when I came back there was only spiders. I tried many things like dropping the quest and logging in and out, and nothing worked. When I logged on today, it seems it is now in an even different phase, as there are now Mogu there instead of the guardians.

As everyone else has already said, this is beyond frustrating, as people cannot do the dailies without first doing this quest.
Same thing happened to me this morning about 9:15 eastern time. Had the 2 quests, was halfway done with each. Went to org to sell and clear my bags and came back to the zone and the spots that had the quilen and crystals was full of only spiders.

This is really irritating cause I cant complete the initial golden lotus quest line to open my dailies, and am falling behind. Please fix this asap.
I have had this same issue, I like the others have tried dropping my quests and getting them agian. I also came back 2 times after doing other things, and still all we see is spiders.

Those of us dealing with this are losing out on Golden Lotus rep, we cannot replace the gap in rep and gear. Falling behind has never been an option. Now I have no choice but to sit and hop that a BLUE sees and reads a post that started 3 days ago.

Please follow up on this right away, were all customers and this is a big issue.
WHAT DO I DO!!!!!!! Only Spiders~ I need my stone guardians back!!!!!!!!!
Yup, I'm having the exact same issue. I've opened a ticket but I don't expect a response. Says 5 days so...lol. Glad it seems to be a known bug though, maybe that means they will get it fixed quickly so we can continue the rep grind. As of right now this bug has stopped my rep grind cold in its tracks. So....
Having the same problem. Tried the obivious things (e.g. droping and re-accepting quests, logging, reloading ui, etc.) none of which worked.

More than a little dissapointing not to be able to grind a rep needed to gear up.
Just hit 90 on my Paladin and having this issue as well. Frustrating that it isn't even listed on the known bug issues.
-crosses fingers that server restarts fix it-
Seriously need a response from Blizz on this. This is impacting game experience. You guys mastermided the rep-in-relation-to-raid-preperation equation, this is a seriously loose variable basically setting people back from getting into raid content. Realm restarting, holding breath for fix.
3 days and no blue reply? Handle your !@#$ bliz, ffs
what he said^^
Having the same issue. No Golden Lotus reputation... Linear quest line derailed by bug and no fix or even a response. Disappointing to say the least. Bugs are annoying, but when it's a necessity to grind Golden Lotus rep to open up other paths... ridiculously annoying.
Even after restart still no fix... gg blizzard.
Stones of power seems to have been fixed (at least somewhat) I found them behind the halfmoon ruins near the bottom but the Killingg the Quilen quest is still glitched
10/03/2012 10:32 AMPosted by Akyun
Even after restart still no fix... gg blizzard.

Seriously this is absurd. Need a response. I really don't feel like dropping 6-16k on BoE's just to be able to raid because one of your content guys thought it was a good idea to prolong the suspense of this expansion with a rep-grind. If that's the way you aim to keep it, fix this damn quest, or just open dailies immediately (or to all 90s). JP capped and seriously don't feel like running more random H since my crap does not drop. One of you guys is responsible for coming up with this !@#$ty idea, make him/her work OT to fix it.
/Also after the server reset i did find some statues down inside the tomb to either side of the pinth? (i think thats the word) the sacrificial alter right at the bottom

Join the Conversation

Return to Forum