Warbanner Intervene Macro (advanced)

UI and Macro
After reading a thread on ArenaJunkies I still can't figure out how to get this macro working perfectly.

/run if not InCombatLockdown()then SB=SB or CreateFrame("Button","SB",nil,"SecureActionButtonTemplate")SB:SetAttribute("type","stop")end
/click SB
/cast !mocking banner
/tar [noharm] mocking banner
/cast !intervene
/cast !mocking banner

What's wrong with this is, it intervene's my current target selected/nearest friendly and

/cast [@Mocking banner] Intervene

doesn't work. I've tried [@mocking] as well but that didn't work either.
Still no solutions found :(
The "stop" secure action isn't really doing anything in that macro.

Try this:

/cast Mocking Banner
/tar Mocking Banner
/cast [help] Intervene
/targetlasttarget [help]

If you have no target, a hostile target, a neutral target, or a friendly target not in the group, it will cast a mocking banner, then after it's placed, using the macro will intervene to the banner.

It only wigs out when you have a friendly target when casting the banner. Then it will cancel the banner, intervene to the friendly and then /targetlasttarget.

If you have an addon to support greater than 255 characters you can do something like:

/run if not DmI then
DmX self:SetAttribute("macrotext",DmX and "/cast Demoralizing Banner"
or "/cleartarget\n/tar Demoralizing Banner\n/cast [help]
Intervene\n/targetlasttarget [help]")]]) end
/click DmI

To make it more reliable with friendly targets, but macro sequences like this can't be reset so it's a toggle kinda: alternately cast a banner and attempt to intervene to it.
I've been running:
#showtooltip Mocking Banner
/cleartarget [help]
/target mocking banner
/use Intervene
/use mocking banner
/targetlasttarget [help]

It will preserve a hostile target, and won't fire accidentally on a friendly target.
The first macro seems to have been hotfixed or something. It was working fine for me for a while and its not longer functional.
10/01/2012 11:12 PMPosted by Vincer
The first macro seems to have been hotfixed or something. It was working fine for me for a while and its not longer functional.

found a way to make it work again with my razer naga, not sure what was going on. I have a bad feeling they dont want use macroing this
When we complained that we didn't want warrior totems, they said to not think of them as totems, for instance you can intervene to these! They even put it on the tooltip that we can intervene to these. (Nevermind that heroic leap accomplishes similar movement with greater range, half the cooldown and less clicks)

Blizzard should be making these easier to intervene. And the blue who said they're not like totems needs to find another reason why they're not like totems.

Join the Conversation

Return to Forum