Unable to purchase Mists of Pandaria, error.

Customer Support
I've been attempting to purchase a digital copy of the expansion over battle.net, my debit card info is correct, I've updated my payment method and profile and still receiving "An error has occurred". I've read the blue thread that acknowledges the issue, but I've been trying to for a few days now with no success.

I've been searching online for my particular situation and it seems I'm not the only one having this problem trying to purchase things off of battle.net. I've attempted called billing and there's a terribly long queue.

Can I get a blue to respond to the situation and possibly inform us what's being done to correct the error? Or possibly assist me?

This is ridiculous.
Get on your game Blizzard.
I am having this same problem, both when trying to purchase the expansion and in attempting to activate my subscription. I've tried about 5 times to purchase Mists and tried to re-sub twice. I really hope I will not be charged multiple times.

This needs to be addressed.
This sounds like a serious issue. I have read of people being charged multiple times and Blizzard has done little in the way of letting the playing public know of any fixes.
Blues on the European threads have only offered the advice of contacting the bank and calling the Blizzard customer service line. The customer service line can take hours to get a hold of anybody and is only open during regular business hours, which is funny considering most people play this game when they are off of work.
Please, Blizzard assure us you are not going to charge your customers multiple times ASAP. I don't think its unreasonable to expect a response.
This is indeed a very serious issue that quickly needs a response.

7 hours and no response from Blizzard. Terrible.
Have you tried using a different browser?
10/03/2012 09:32 PMPosted by Wraylas
Have you tried using a different browser?

10/03/2012 01:57 PMPosted by Adiemus
I've read the blue thread that acknowledges the issue

It mentions that. Doesn't work.

I've resolved this issue - for me at least.

What I ended up doing was editing my existing credit card information under settings>my payment options. Try this, and then try to purchase again.
I'll try that when I get home.
Update: Problem seems to have fixed itself.
I am still having this issue.
I'm having the same problem also
Have you guys gone through this?


If that doesn't work, try Zippz info, I didn't have time to do it, so who knows, if it worked for him it could for you fellas.

Also, make sure the required amount is in your bank before using a debit card, if that's what you're using.

Could use some help from the community here as well (I'm talking to you, forum lurker), any ideas for a workaround would be greatly appreciated.
Try deleting your payment option in your account setting and trying again, that worked for me.

Join the Conversation

Return to Forum