To the Rescue! Questions

Hi, I am in the middle of the quest "To the Rescue" in Orgrimmar. I have to talk to an NPC when I am ready to depart for the next section of the quest.

I talk to the NPC but he always gives me the same response, and my only option is to "Check in with him shortly", I have been trying to complete this section for over 10 minutes, can someone please help me?
Ach, THAT quest. Sooo horribly buggy.

Check here:

For one thing, make sure you're speaking with Kadrak at the Barrens/Ashenvale border, Mor'shan Rampart. In theory, he'll tell you to hop on his nearby kodo, then on the way to Splintertree you'll be ambushed a couple times by night elves, but the kodo will handle the attacks if that part isn't bugged too.

Have you tried abandoning the quest and getting it again? And are you dismounted when you speak with him?

From what I can tell, the only solutions to that part seem to be either killing Kadrak, or just submitting a ticket...might try abandoning the quest, then logging out and back in, that'd be one quick thing to try.
Yea i had the same problem. I abandon quest logged retook quest. And Kadrak still says Brutusk is watering the bush's. Submitted a bug report.
I tried abandoning it and getting it again, logging out and back in, everything you mentioned. I am unmounted, and I am talking to him at the Ramparts, it still won't work. I wasn't aware this quest in general was bugged, kind of inconvenient that it is though.
so very annoyed by this quest!!!
still broken lol
So glad to know it wasn't just me. I was going crazy trying to figure out what the issue was and why I could not complete this quest!
Trust, it's still broken, trying to do it right now on my SPriest and I can't do it. Same stuff keeps happening to me and it's annoying. Even traveled to Splinterwood on foot and Kadark was there and it wouldn't let me talk to him still. So I abandoned and took the quest again, but nothing works. Still the same stupid response. Lame.
Sadly, same issue here.
I'm having the same issue. I've been waiting for like a half hour.
This is bull.....fix the damn bug/glitch so we can actually do some questing in ashenvale.
sigh. still no fix.
Bugs like this make my forehead veins show. It betta' be fixed soon, ya huurd?
Well almsot half way through December, 5.1 and 5.1a and they still haven't fixed it. At least you can skip it and pretty much just go straight to Silverwind camp and then to Stontalon
I sent a ticket in and I got a response :) I got the quest finished by the GM.

Just send a ticket in to have it finished ;)

The more tickets sent in about the quest the more likely it will be fixed, removed, or replaced.

From what I've read, it's been 2 years of bugs for it.
It worked for me whern I waited until he walked over to the east side of the road. On the other side, he just keeps giving the same answer.
Hey Blizz.... how about a permanent fix? What are we paying for?
1. It won't be fixed until an expansion either changes the quest or its eliminated. This one has been broken since 2010, according to posts on WOWhead.
2. There are ways around it, such as logging an Ali and killing the npc's...this is supposed to reset them, then the quest works. I haven't tried it.
3. At least you got a response. I sent 2 tickets, didn't get a response to either one. I sent in 2 more for another broken quest- no response to those either. I tried asking politely, but gave up.

Broken quests- at least those that never get fixed- are a pet peeve of mine. Time & effort can be spent on any number of other things, like introducing more vanity pets, but basic quests with simple problems don't get fixed.
I just tried the quest and it is still not working im getting the same response as everyone else.
still not workin guess i'll just have to skip it. stupid that i just can't complete it

Join the Conversation

Return to Forum