To the Rescue! Questions

This is the second bug I have run into in Ashenvale. The first was that when Mists of Pandaria update came out the design of the machine in the skunkworks was changed so now you can not get to the bomb to get the quest. At least that is not a major quest that would not let you advance. But you can not do anything if you dont finish this quest. But it worked for me if you just wait for him to walk to the other side of the road then talk to him.
Omg this is bull !@#$ it still hasnt been fixed im getting tired of this i had problems with it on one of my other toons
It's been broken forever.
The only way I've been able to get it done is to abandon, relog, and pick it back up repeatedly until I can get it to complete. It's doable, it just takes forever and some RNG.
Still bugged :(. Why is the quest still offered if it can't be fixed?
same problem... still broken... what the.... Blizz do something!!!!
Yep stuck on this one on my monk plz blizz fix it already
This is driving me crazy.
omg... ive been waiting an hour....
Still buggy after 5.2. Same thing happens. What the hell Blizz? Fix the bug already!
Glad to know it is bugged, although very inconvenient. Guess I'll have to skip it.
I don't understand what happened to this quest. Pre Cata it was fine, after its release that's when the bugyness started to happen, at least for me. It was doable then, but now i'm stuck waiting for Brutusk to finish 'watering' the bushes and from what I see here, its been like this for years. I also wonder when Blizz is going to fix the worgen starting zone?
Still bugged. Seriously, Blizzard - a quest that has been bugged for going on three years?

Someone get on the ball and spend the time to get this fixed. It's sloppy.
Oh well, I guess I'll just abandon it!
I had the same problem and nothing worked... except when I complete a dungeon. Once I warped back, Kadrak was ready to go. I guess he just wanted to ensure that I wasn't a pansy.
This quest is still not working... So just know that...
For the love of God, Blizz, it's been several years now and this quest is still broken. Fix it! It's sad that in all this time you haven't been able to give this quest the time of day.
08/06/2015 02:44 PMPosted by Yaholo
It's sad that in all this time you haven't been able to give this quest the time of day.

What's sad is that people immediately jump to this kind of conclusion.

During MoP they added the option to talk to Kadrak and he'll just fly you there. It's not intuitive and they'd be better off just leaving Brutusk out of it completely, but they obviously haven't ignored this quest.

The wowhead link again:
to the rescue didnt work for me either

Join the Conversation

Return to Forum