Retrieving Item Information

Technical Support
I posted this in the Customer Service Forum, but there doesn't seem to be any customer service actually going on there, so I'm reposting it here.

I am having an issue where it is taking a while for the game to retrieve item information on items. This happens when I try and loot a mob that has an item on it that I haven't seen yet or go to a vendor that has new items. I will eventually get the item information, but the time it takes is ridiculous. It kinda sucks killing a mob and then having to wait 30sec to a minute to move on.

I have tried several things to fix this, none have worked. I have tried disabling all addons, deleting my WTF, Cache and interface folders, flushed/renew my dns, disabled my firewall and antivirus. I even reinstalled the game. It is getting extremely frustrating.

Any help on this issue would be appreciated.
Bumping this off of page 10 :/
bump
I ran into this myself; turns out the problem was with my bag mod (FamBags.)

As soon as I disabled it that problem went away, so if I had to guess its a mod.

Also, I did clear my cache as well, so that could help.
I ran into this myself; turns out the problem was with my bag mod (FamBags.)

As soon as I disabled it that problem went away, so if I had to guess its a mod.

Also, I did clear my cache as well, so that could help.


Well, as you can see in my first post, I have already disabled all addons, wtf, ect. Good try though.
I've got this same issue. Already tried disabling addons and clearing my cache. So far no luck clearing this up.

Join the Conversation

Return to Forum