Error:WoW\Data\texture.mpq could not be writt

Technical Support
Running across this error while trying to do the "optimization". Trying to update game to v5 from v4.3.4.15595. It downloads new tools then wants to run the "optimization". It got stuck at 0.7% for 3 hours then I stopped it. Tried again and this time getting this error:

Error:WoW\Data\texture.mpq could not be written. If this problem persists please contact Blizzard Tech Support. (OpenRepackTarget: PreAllocateStreamedMPQ).

Second time I tried it gave me this error:

ERROR: The file C:\Program Files (x86)\World of warcraft\Data\base-Win.MPQ could not be opened. (OpenRepackTarget::OpenMigrateMPQ)

Please help. Windows 7. I installed the program outside of the Program Files folder structure. The path is C:\World of Warcraft.
Plin

Are you running the launcher as an admin by right clicking on it and selecting "Run as admin"? If not, go ahead and try that.

Also, what security programs do you have installed?
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time
Hi Dankorii,

Yes, running as admin. I right clicked on the launcher exe and clicked run as admin. Got the first noted error above this time. I normally run Zone Alarm but I closed it down for this. Windows firewall is turned off.

Thanks
Plin

Zone Alarm has been known to interfere with our games before. It may need to be temporarily uninstalled to know for sure if that is the cause, but lets first try something else.

Try this:

1. Make sure that Windows is set to show hidden files.

Here's how to do that: http://windows.microsoft.com/en-US/windows-vista/Show-hidden-files

2. Navigate to the C:\ProgramData folder and delete the Battle.net folder.
3. Navigate to the WoW folder and delete the "Updates" folder.
4. Launch WoW.

Let me know what happens.
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time
It has not given me an error yet. The optimizer has been on for about 30 minutes but is still at zero percent. I am logging off now and going to bed. If you reply I will see it in the morning. Thanks for your help so far.
Plin

Oddly enough, it might have actually been downloading when it looked stuck at zero percent. That happened to me at home, I left it and next thing I knew it was done optimizing. You might want to give it a little more time before turning it off. The optimizing can take about an hour or so depending on the system.
________________________________________________
Support Information Administrator
If you can't find a solution to your issue, feel free to contact a Support Representative directly for further assistance. Their contact information can be found at the following link: http://us.blizzard.com/en-us/company/about/contact.html

I'm available on the forums Monday through Friday from 11AM to 8PM Pacific Time
I've been having the same problem as Plin. I've looked at like thirty different forums and tried almost everything and i keep getting the data/texture can't be written.

Join the Conversation

Return to Forum