Bug: August Celestials Dailies 10.10.12

Bug Report
Two of us grouped up for these dailies at Niuzao Temple today. We flew over to the temple on Draka, picked up the quests, but could only complete one (where you kill 25 mobs; sadly I can't recall its name.) We still have the following quests to complete:

The Big Guns
The Overwhelming Swam
In Battle's Shadow

We can't do any of these. For "The Big Guns," there are no war wagons to explode. They are simply not in existence. For "The Overwhelming Swarm," there are no Kunchong to kill. And for the last one, there are no loose bricks. When we click on the quests we get the map highlight for the area (we've done this particular set once so know what to expect) but the stuff simply is not there. We've tried abandoning them, reloading UI, picking them up again, dropping group, and nothing works.
Same issue here. I have done quests in the area before and seen the vehicles. But the first day I opened up the dailies I can't see the war wagons, kunchongs, or stones to throw. I tried dropping quests and relogging and can't think of anything else to try.

Edit: Fixed after server restart.
Same thing is happening to me today. Tried dropping the quests and still have the same issue. I was able to do the 'kill 25 enemies' quest with no problem, but those three quests won't work due to the required targets never spawning. Other people in my guild have the same issue.
Can't do "The Big Guns" here either. The required War Wagons do not exist. I even tried having Real ID friends invite me to their realms, they weren't spawned on any of the other realms I checked.
I have had the same issue. Same with many guild members, and people in the zone.
Same problem here. Very frustrating since I really need these dailies and don't have many days that I can log on to do them. :(
Everyone is having the same issue today so I guess the problem hasn't been fixed yet. It was nice to see confirmation of the problem as this is the first time I was doing this and didn't know if I was missing something I wasn't doing.

Join the Conversation

Return to Forum