[It Belongs in a Museum!] achievement bug

Bug Report
I had progress of 19/20 towards this achievement, on this character, and then I solved my last rare, "Spear of Xuen". Instead of getting the achievement, however, my counter reset to 1/20.
If it matters, I got the "the Four Celestials" achievement while solving that rare as well.

Already filed a ticket, but I'd also like to report this as a bug here so that it can be looked into won't happen to other people. Thanks!
Same thing just happened to me. I logged in and it said I was at 1/20. I solved a rare and was brought to 2/20, logged out and back in to see if it would fix itself, and I was back to 1/20.
This just happened to me as well. I was at 19/20...I solved one and now it says I have 2 rares.
Last night I was questing on another character in Tian Monastery in the Jade Forest. I had just taken the quest from High Elder Cloudfall at the end of the 'welcoming' feast where your character gets 'drunk' vision and lies down and passes out (and all the NPCs that were eating disappear.)

At that moment, my character suddenly got the achievements "It belongs in a Museum" and "Diggerest". Needless to say I was not doing archeology at that moment, nor had I done any that evening!
Happened to me with both "Diggerest" and "It Belongs in a Museum".
Diggerest is at 2/100 when I have exactly 100 common solves in my Archeology Journal.
It Belongs in A Musuem is at 1/20 when I have 19/20.
I also recently solved the Spear of Xuen, last night on October 2nd, though my last solve was a common artifact (Empty Keg of Brewfather Xin Wo Yin).

I opened a ticket, but I hope it gets resolved in some form or other. That stuff wasn't easy to get!
This has happened to me as well, I should be 15/20, instead I am 1/20, same with the diggerest one as well, i have a ton of common artifacts however it is saying i only have 2.
I too have lost all progress in both It Belongs in a Museum! and Diggerest. My last Rare that I solved was Quilen Statuette.
Same issue
Same thing happened to me, I was one away from it and now it says I only have 1. I was really looking forward to finally getting my Professor title too. ):

I hope they fix this soon.
Same thing is happening to me. Please fix, Blizzard. D:
I had the same thing happen. I even have 20 different rares listed in my archaeology log.
I just noticed that I'm having the same problem. My archaeology log reflects that I have 15 rare finds (all of which I even still own in my bags/bank), but my achievement progress shows 1/20. Same for Diggerest; I have 85 common finds in my log, but my achievement progress shows 1/100.

Please fix this, and soon!
just noticed this as well
Oh, apparently this happened to me as well! The only rares I've solved in the meantime have been the Spear of Xuen and the Anatomical Dummy.
I just noticed that my achievement says 2/20 after getting my first pandaren rare (Spear of Xuen)*cheers* even though I have 20 rares logged in the arch journal. I really hope this gets fixed soon! :(
Same issue hope this is addressed soon.
The same thing has happened to me. Sucks. =(

My [Diggerest] achievement has also reset back to 1/100.
Both [Diggerest] and [What was Briefly Yours is Now Mine] are stuck at 1 for me. Looks like I'm bugged too.

Join the Conversation

Return to Forum