Unable to learn how to smelt Dark Iron Bars

Bug Report
Recently, I completed the quest http://www.wowhead.com/quest=4083 which is a requirement for being able to learn how to smelt Dark Iron Bars. Once I completed the quest, the NPC never gave me the option to learn the spell. Whenever I go back, I still have no option.

I did put in a ticket and the GM told me that this was a known bug. However, searching this form and the known bug list and I did not see it listed. Just want to bring it up because I would love to make my Sulfurion Hammer soon!
d0h.....also completed this quest and unable to learn the skill :(
I had put a ticket in to the GM's last Tuesday about this, i had retook up mining and it doesn't give me the option to relearn dark iron smelting. And the chalice isn't next to him either to put the items into.
All i was advised by the GM they would forwarded it on to their bug report team.
Haven't heard of anything since, and just check and found that I still cannot relearn Dark Iron Smelting.
Been almost 2 weeks now and still cannot learn how to smelt the Dark Iron Bars. :(
After 4 attempts to talk to someone at blizzard about this i finally got (after the normal your doing it wrong and delete your WTF folder)

"I'd like to apologize for the confusion. The bug was listed under a different category and that was the reason it wasn't found. I've added your information to the bug report that I was able to find for issues with not getting the spell for smelting Dark Iron Ore. Hopefully the issue will be resolved shortly but I have no estimated time for being fixed. "

This was on Oct 29th 2012.
Add my name to the list of folks that have gotten the run around on this. I'm sure this isn't a 'high' priority for THEM... but for those of us that need dark iron bars it kinda is.

here is what I got after asking for the quest items to be returned and the quest cleared from my completed since apparently its a 'known' bug.

Thanks for contacting Blizzard Entertainment, Game Master (editted) here to
help with your issue regarding the skill Smelt Dark Iron.

As the previous Game Masters have said, there isn't anything we can really do
in terms of this quest until a fix has been made. The items used for the quest
cannot be returned because they were consumed by the quest completition. We
also can't clear a quest that you've already completed from your quest log.

Your question about being unable to complete it in the future when it does get
fixed is very likely true, however since you've already completed the quest, the
ability is something that probably should be able to be added to your character
automatically or something that you could be granted. Either way, since we
don't know exactly what the fix will be, we won't be able to take any actions
until that fix is actually in place.

basically I read it as its broken, and we dont care.
just ran through black rock depths again...still not working >:( this is ridiculous
I did the quest also cant they fix it ???
apparently not they're too lazy and just don't care...its a simple problem...
if anyone runs through and it works please post here so we can know that it's working again
I'm another person that can't learn to smelt these darn things. Please fix it.
everyone please request sticky so that blizzard see's this and submit bug reports
Got an answer from a GM. A fix is slated for 5.1. This coincides well with the removal of the raid group requirement for entering old raid dungeons.
damn...gotta wait till early december then :(
How do they manage to break something that has worked for so long in a dungeon that does not appear to have changed with MoP????

Not everyone wants it, but those who enjoy mining and crafting weapons and special items certainly do want to have it.

I can't make weapons like the Dark Iron Rifle because I can't learn the skill now, no one in the guild has it, and anyone on the realm that has it wants a ridiculous amount of gold to be bothered with it.

They already yanked a lot of classic plate recipes it seems, which used dark iron, but there are still some nice ones and the legendary items that require it as well.

Blizz is so worried about appearances, so after every ticket, you get a survey. You'd think that the tickets would be a pretty good indication of where the issues reside and what needs fixing.

Things like this, that persist in the game after so many years, are why the number of players has dropped significantly and why even those of us who have been playing since the beginning are beginning to lose patience.

It's just annoying and anyone saying otherwise is simply "talkin' out their !@#$" LOL
I had that issue about a month ago. Sad to see it is still not fixed. I will say that the GM WAS able to return my items.
FIXED!!! :D :D :D
Really???? What was your trick?

I went in and it failed.

I had the items and all I kept seeing was the guy's text speech.
I had the same problem but I just went to BRD again and glom'rel finally gave me the chat option that taught me the skill.

I confirm that as of 12/12/12 in patch 5.1.0a the quest is working again (you do not need to turn in materials again if you had already completed the quest)

Join the Conversation

Return to Forum