Low FPS/Performance Issues [formerly @known issues (10/8) update]

Mac Technical Support
Prev 1 5 6 7 Next
Installed 10.8.3 beta to see what impact that has. This release has updated graphics drivers that I hope will contribute to better performance.

Unfortunately though, I have had flawless performance on all of my Macs and PC's until Pandaria was released. Every single hardware and OS combination have been impacted - some have gone from 100fps down to 20fps.

Given this, I am fairly confident that this is a Blizzard issue rather than an Apple OS X or Microsoft Windows issue. It's the only constant.
I see blizzard replying to other posts but this is just going unanswered. admitting to having a problem and working on a fix would be better than leaving paying customers in the cold.

I have believed this to be a blizzard issue all along and agree with Drelf. its the only constant.

Come on blizzard. at least confirm something. give us some shred of hope that not only are you aware of it but a fix is on the way.

is this really too much to ask for after 2 months?
Still having problems.... Still waiting for anything....
11/30/2012 11:11 AMPosted by Dondu
Still having problems.... Still waiting for anything....


My take on it is that this is the new normal. I've really lost faith in Blizzard. I've gone from playing 3-4 hours a night to 3-4 hours a week, and those hours that I do play are frustrating and not very enjoyable, because of this persistent FPS issue. I've given this game well over a year of my life if you look at my /played, and it's really disheartening being ignored when there is a problem after being such a loyal player for so long. I've kept my subscription going, because I really don't want to leave this game, but with each frustrated log out it's seeming more and more like a complete waste of money.
Perhaps this is an elaborate plan to drive up computer sales. Im game if blizzard wants to buy me a new mac

for years I would laugh after reading post from people saying they wanted a refund but I honestly get it now. I am frustrated to no end

to just to pour some salt into the wound blizzard has the balls to send me an email to upgrade to mist...

I already have it. you have my money. would you like my first born as well???
I'm not a programmer or 3D modeler/animator, so I'm probably talking through my hat, but I'm starting to get the impression that the game is trying to render objects that are simply too far away to be important, regardless of "View Distance" settings. Like, perhaps it's trying to render everything all the way to the zone border when, even with View Distance set to "Ultra" you still wouldn't normally see that far. Even with my View Distance set to "Low" and the "fog of war" obscuring my view past 100 yards or so, FPS is disgraceful, as if the FoW is simply hiding things that the game is still rendering.

What makes me think this? My hunter was at the Shado-Pan Fallback in Kun-Lai, inside the building where you get the quests from Shado-Master Chong. Being inside a building, with all the doors closed, there is really no reason to render objects in the distance because I can't actually see any farther than the walls, which are less than 10 yards away while standing in the center of the room. Yet, if I faced my character South or West (the sides of the building that are effectively up against the southern zone border), my FPS was over 50; if I faced North or East, my FPS plummeted to 15-17.

I've gone so far as to go into the System settings and reduce my in-game screen resolution from my Mac's default 1680x1050 down to 1518x948, and leaving all the other graphics settings on "Low" or "Disabled". This produced an immediate FPS improvement, getting me around 30 FPS ... until I happened to face my character toward the most distant zone border. Then it was right back to 15-17 FPS.

I also have a sneaking suspicion that when the Sha of Anger spawns in Kun-Lai near the Golden Gate, it's affecting the Vale FPS-wise. I don't see its graphical effects while in the Vale, but I can "hear" all of its "/yells". In the past, /yells never extended past zone borders like these are; perhaps other Sha effects are spilling over.
12/01/2012 05:11 AMPosted by Jenyala
Still having problems.... Still waiting for anything....


My take on it is that this is the new normal. I've really lost faith in Blizzard. I've gone from playing 3-4 hours a night to 3-4 hours a week, and those hours that I do play are frustrating and not very enjoyable, because of this persistent FPS issue. I've given this game well over a year of my life if you look at my /played, and it's really disheartening being ignored when there is a problem after being such a loyal player for so long. I've kept my subscription going, because I really don't want to leave this game, but with each frustrated log out it's seeming more and more like a complete waste of money.


I am in the exact same boat. Me and the rest of my family will not be renewing our subscriptions. There was hope that 5.1 would fix these problems, but it didn't address any of the graphical issues. We will miss WoW quite a bit.
my subscription was up this month, and this was the primary reason i didnt renew, while using a back up graphics card was a temporary fix for me, it was just that , temporary. The back was was a back up for a reason, and that is it ran to hot for my liking. Ill give it a couple of months, come back to the forums, and see if its working again. I mean this was almost two months of the game not working properly and I just cant justify paying for that
Good thing I checked this before renewing my subscription. Is this for all macs? I have a 2009 MBP 9400m
It seems to be entirely random what macs it affects. I have a mid-2010 MacBook Pro that is affected, but not as badly as some. Meanwhile our new iMac is not affected at all, yet others that are 2012s are.
it is randomly affecting systems both mac and pc and as far as I can tell blizzard is well aware of it but has not addressed it other than to throw a few bandaid fixes around.
My new iMac is all over the place performace-wise with WoW
Just to restate: This seems to be an issue running WoW on the Mac operating system. I had all these performance issues mentioned above until I started running WoW on Windows XP through Bootcamp. Now my performance is consistent and very good. I know others have experienced the same. Yes, it's a pain restarting every time I want to play WoW, but worth it. Once Blizz figures out a fix, we can go back, but I highly recommend this until they do.
sorry but this is not just an issue with wow on mac. Ive been keeping an eye on all forums and it is affecting pc as well.

I am happy for those that are able to play wow under bootcamp but I multitask and personally do not care for windows. so to have to run bootcamp just to play wow after 2 months is not worth it at all.
My problem happened about 2-3 days ago. The game would stutter every 15-20 seconds, for a about a few seconds, then it would be normal. This would happen everywhere: inside or outside instances. I've tried all the lower resolutions but the problem persists.

This is on a Mid-2010 iMac.
Is there any update from a blue post on this issue? This has been an issue that has been going on for months now. Any possibility of a fix before the next expansion comes out?
I would love an update on the issue too.

Earlier, I tried checking Sharing and Permissions, using Disk Utility (Repair Disk Permissions), deleting the Cache folder, and moving the Interface and WTF folders out of the WoW folder -- which was suggested on a blue post in a different discussion. I even set my FPS to 60 max as suggested by others too. I thought this fixed the issue because the game was going great for a few minutes. Then the stuttering happened again.

My only fear is that my graphics processor is not working as well as it used to. But still, it's operating at 60C-80C (as reported by Hardware Monitor), stuttering shouldn't happen.
Listen up people. specially those with fps or stuttering issues. it is my belief that the given possible "fixes" were not meant as permanent but there is nothing wrong with troubleshooting given the many differences in hardware.

there is a serious lack of concern on blizzards part and that concerns me more than the issue itself.

for many years I have weather many updates, patches and expansions and we got through them but this one is not getting the attention it deserves.

why it is not I do not know but I do know this.

regardless of what others are saying. we should not have to cap fps or turn settings down or run bootcamp just to play wow.

this has gone on long enough.

blues havent given up on this thread as they have no answers.

FIX IT!
So I bought several compressed air cans and opened up the iMac. The first blast literally poofed out a cloud of dust. I also gave the graphics card fan's fins a good blast.

I flew around and did a Scenario. The good news is, it looks like my problem is GONE.

The temperature now goes from 40C-75C so I guess the problem was ventilation.

I'll observe more...
Had you been having problems with any other programs besides WoW? Has your computer's performance improved overall?

Join the Conversation

Return to Forum