Keyboard run keys get stuck

Mac Technical Support
This is happening to me at least once every 45 minutes, where one of my running keys (WSAD) gets stuck and forces me to run non-stop in a certain direction. Nothing short of facerolling my keyboard breaks the bug.

Is anyone else having this issue?
Have you tried cleaning your keyboard? If it is physically sticking, that's the first place I'd look. If however, it's not physically sticking, but is remaining in the "KeyDown" state after pressing it, I'm guessing you've got sticky keys turned on and managed to press the same key enough times in a short period of time to activate that feature.

To make sure sticky keys are disabled, do the following:

1) Open the System Preferences in the Apple menu.
2) Click the Universal Access icon.
3) Click the Off radio buttons for both the Sticky Keys and Slow Keys options.
4) Close the System Preferences.

Assuming your keyboard isn't on the fritz, the above steps should quell the aberrant behaviour.

Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
I started having this issue this week as well... thought my keyboard was gunked up... nope... not sure whats causing it. Noticed it after last weeks rolling restart.
I checked Sticky Keys and Slow Keys and both were already turned off. It's definitely not my's very clean and it's one of the newer models where the keys are raised just a little bit from the metal.

Shost, it just started happening to me within the last week or so also. I'm sure it's WoW-related...whether it's a mod or WoW in general is hard to say.
The only mod I run is auctioneer.... so its hard to say. If the servers ever decide to come online again I will disable it and see what happens. I dont have the issue at any other time, in any other game. Only in WoW.
i have the same issue. I seem to happen when using multi keys and mouse at the same time. I have to click the same button again to stop it... like if flying i will just keep going up, until i hit space again.... bugs the crap out of me.

I am running macosx 10.7.4 - macbook pro. 8gigs mem i7 proc....
Can we start seeing some system specs for this and we can look into it.

    1. Launch World of Warcraft and log in.
    2. Put World of Warcraft into Windowed Mode if it is not already in Windowed Mode.
    3. From the system menu bar, select Help > Copy Support Information:
    4. Paste the contents of the copied system information here (Command-V)

same issues. dealing with this for a while.


System Software Overview:

System Version: OS X 10.8.2 (12C3006)
Kernel Version: Darwin 12.2.1
Time since boot: 1:45


Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.7 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B02
SMC Version (system): 2.3f32


Intel HD Graphics 4000:

Chipset Model: Intel HD Graphics 4000
Type: GPU
Bus: Built-In
VRAM (Total): 512 MB
Vendor: Intel (0x8086)
Device ID: 0x0166
Revision ID: 0x0009
gMux Version: 3.2.19 [3.2.8]

NVIDIA GeForce GT 650M:

Chipset Model: NVIDIA GeForce GT 650M
Type: GPU
Bus: PCIe
PCIe Lane Width: x8
VRAM (Total): 1024 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd5
Revision ID: 0x00a2
ROM Revision: 3688
gMux Version: 3.2.19 [3.2.8]
Color LCD:
Display Type: LCD
Resolution: 2880 X 1800
Retina: Yes
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
Built-In: Yes
Connection Type: DisplayPort


Input Source ID:
Keyboard Layout: ANSI
I have this happen to me as well. The only workaround for me is to spam press (not hold) random movement keys until it "unsticks". Been happening since 5.0.4 but I just deal with it.
Can you give me an example of what exact keys you've experience when this happens?
Totally not "worth dealing" with.

Super frustrating in pvp as you try to get to a position... and you're stuck! In serious bouts... it could almost cost you a match...


- Pvp.
- Fast movements. Straffing, etc.
- Sticky key moving right.
- Move to left and ... my toon just stands there. Cuz the sticky key is holding me to the right.
- So i stand there till i (quickly) realize taht i need to double tap the "right key" to unstick me, then i can move left.
This hasn't happened to me in ages but all of a sudden it's happening all the time today.

It's when I'm moving and has to do with some combination of WASD (S and D set to strafe) and right-clicking with my mouse to move me camera.

EDIT: I can never reproduce it purposefully. but it seems most common when using S to strafe left.

EDIT2: My S key will randomly stop working too. I have to press it 2-3 times to strafe.

I've had my current mouse (Razer DeathAdder 3500dpi) for years and my keyboard (Razer Blackwidow 2013) for a few months, it's weird that this just manifested itself.
For me, at least, it's the mods Grid and/or Clique.

I can duplicate it every time when I strafe left (A key) and click in grid with my right mouse button.
Had the same issue, try this:
1) Open System Preferences.
2) Open the Keyboard settings.
3) Turn off the Key Repeat.
This is still happrning A LOT for me with Key Repeat, Sticky Keys and Slow Keys all OFF. It can happen with any key - I've mostly experienced it with the WASD keys and the space bar.

It was happening in both Mavericks, and it has been happening through all of the Yosemite developer previews (currently runnin DP8). It's happening in both live and the WoD beta as well as Diablo 3 and Heroes of the Storm. Haven't noticed it in any non-Blizzard games which makes me believe it's a Blizzard thing.

Would be nice if you also fixed the game hiding bug that has been happening lately in all your newer games (D3, HotS, WoD beta) where if you lose focus on the game in windowed mode it just hides completely. Shame you just seem to be ignoring Mac users yet again.
This is a blizzard thing. It also never occurs in true full screen mode. It seems to be a bug with windowed mode and window focus. What happens is something steals window focus while you have a movement key down, and when you release the movement key the window ignores it because it didn't have focus when the key up event happened, so you have the Perm down effect. this can happen from a lot of things like a growl notification, an instant message, etc. Even if you don't think the window lost focus, it did, very briefly even if it was returned to focus near instantly.

The issue is easy to fix, you simply press the "stuck" key again then release it. so app can see key release event and unlock the stuck key.

So if you want to completely avoid, play in full screen so it's impossible for OS/other apps to steal window focus , or just get proficient at dealing with it, maybe minimize applications that may take focus such as instant messengers or notifications while playing.
I have the same issue as well. Typically the A and D keys and space bar. This has been happening off/on for years and on different keyboards.

By the way the only reason I am mentioning it now is that it has been happening a lot more since I came back. I've been away for about 2 years. I'm back now, on Yosemite beta. I don't see an option to turn off sticky keys yet. Stuck keys happens a few times an hour. I even turned off notifications, not that I saw any coming up when it happened in window mode. My keyboard is clean/brand new.
I'm currently having the same issues. The stuck key issue seemed to manifest in Mavericks, now in Yosemite. I've checked all my Accessibility/Keyboard options in Yosemite and the issue persists. Even changed my keyboard. Omega's post above looks right on and I will follow his advice to confirm his assumptions.

For the Blizzard Support, here are my specs. If other information is needed, let me know.


System Software Overview:

System Version: OS X 10.10 (14A389)
Kernel Version: Darwin 14.0.0
Time since boot: 8 days 18:10


Hardware Overview:

Model Name: Mac Pro
Model Identifier: MacPro3,1
Processor Name: Quad-Core Intel Xeon
Processor Speed: 2.8 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache: 12 MB
Memory: 20 GB
Bus Speed: 1.6 GHz
Boot ROM Version: MP31.006C.B05
SMC Version (system): 1.25f4


ATI Radeon HD 5870:

Chipset Model: ATI Radeon HD 5870
Type: GPU
Bus: PCIe
Slot: Slot-1
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6898
Revision ID: 0x0000
ROM Revision: 113-C0780C-194
EFI Driver Version: 01.00.436
Cinema HD:
Display Type: LCD
Resolution: 2560 x 1600
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: CY8341EMXMP
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported


Input Source ID:
Keyboard Layout: ANSI
I disagree, this happens for me in fullscreen mode. No other applications running.
This is happening to me at an alarming rate... just today had it happens 10 times with in a matter if minutes.
I really hope this get looked into in depth. For questing and what not its no big deal....but for challenge modes, heroics, and raids...its a deal breaker.

Early 2011 macbookpro

Join the Conversation

Return to Forum