Game freezing during logout..

Mac Technical Support
Like the title states. My game constantly freezes at logout. Now I have to play in windowed mode just to get out of the game and not just the whole mac down. Any thoughts?

How long are you letting the game sit before force quitting it in fullscreen mode after logout? My client takes between 15-30 seconds to write all of the saved variable info from my addons after each logout, and that's on a Vertex 4 256 GB SSD with less than 30% filled (meaning I'm still in performance mode).

It is entirely possible that your game is writing quite a bit of information out to files during logout, especially if you have Prat installed and are using any of its various log files, or the Armory addon, which re-writes everything it stores in RAM upon logout.

Official Mac Tech Support Forum Cookie™ (Mint Chocolate Chip)
Guaranteed tasty; Potentially volatile when dipped in General Forums Syrup®
Caution: This cookie bites back.
I have the same problem. I wait for a few minutes before powering down.

Tried deleting the Cache, Data, Interface, and WTF folders to solve the problem. It merely reduces the number of logout freezes but it doesn't eliminate them.
Just found these 2 older threads a few minutes ago. Something else to try.
I've had no luck stopping this.

I tried disabling the out of date mods. Still freezing.

I deleted the Cache, Interface, and WTF folders. Still freezing.

Checked my software, everything is up to date.

Stopped running other programs. No luck.
I am also having problems on logout and exiting the game. Last night, I exited the game only to have it freeze up with only about 3 seconds to go. I couldn't do anything. I couldn't Alt-M to go to windowed mode. My computer was totally stuck. I had to power down. Then, today, I was logging off (I was in the game world, not in the city. I just realized this), when the game crashed and I got an error log. Sent the log to Blizzard with my comment. I should have read the log, but I didn't. Then I came to the forums to see if anyone else was this issue. I see I am not alone.

I'm running OS 10.6.8

Hardware Overview:

Model Name: iMac
Model Identifier: iMac8,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.66 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 6 MB
Memory: 4 GB
Bus Speed: 1.07 GHz
Boot ROM Version: IM81.00C1.B00
SMC Version (system): 1.29f1
Serial Number (system): ----
Hardware UUID: -----
Try running the repair tool and see if this helps in any way.
Mac Technical || Sun – Thur, 11 AM – 8 PM CST
Need 1x1 help?
Rwlrlwrlwrl wrlrwl rwlwrlw rlwrlwrlwr wlrwlwr grglblrglglr? Wrwlrwl rarwlwrlwr grgrblgr!
I did what you wrote in this thread:

Hey Tiernacht,

For the moment, can you try repairing your permissions and reset your UI and see if this helps?

Reset the permissions on your World of Warcraft folder
1. Select the World of Warcraft folder
2. Press Command + I
3. In the Info box, go to the Sharing & Permissions section and click on the lock and unlock it, entering your admin password when prompted.
4. Make sure you have Read & Write permissions
5. Click on the Action icon (cog wheel) and select Apply to enclosed items
Repair Permissions via Disk Utility
1. Navigate to /Applications/Utilities/ and open Disk Utility.
2. Select the hard drive the game is installed on.
3. Select the First Aid option.
4. Click on the Repair Disk Permissions button.
Reset the temp files
1. Navigate to /Applications/World of Warcraft/
2. Delete the Cache folder.
3. Move Interface and WTF to the Desktop.
4. Launch WoW.

If this doesn't, we may have something else to help out.

It seemed to help. I left it on the default ui for about a day. Then I added a few addons a bit at a time and I haven't had any problems since.

I noticed the original poster in that thread didn't reply back, so maybe it worked for him as well.

I'll keep this in mind, if the problem happens again.

I'm still having the problem. I deleted all the mods. Deleted the Cache, Interface, and WTF folders. Ran the disk and disk permissions repair utilities on my iMac. Used the Warcraft repair tool after that.

It still locks up while logging out. -_- It also just started locking up while logging in. >.<
Having same problem, freezing up on logout, same with changing resolution.
Try this and see if it helps.

Let me know if this helps.

Join the Conversation

Return to Forum