Launcher reopens launcher when you push Play

Bug Report
I've got this issue where my WoW launcher reopens itself instead of the client. I'm not sure how to fix this. If someone could help me out that'd be great.
Have you tried running it with administrative rights? It could be attempting to update WoW but getting stuck in a loop due to insufficient rights.

If that does not help it would be best to seek assistance on the Technical Support forum.
I just tried, and it didn't work. I'll make my way over there, thanks!
Before you try complicated fixes, change your language to Spanish, then back to English. Should make your launcher force update, thinking it has to translate the game.

They really should include a launcher/client force update option within the launcher preferences.
Skeinhammer, that's the perfect solution! Thank you SO much! I had actually performed a System Restore because I saw some funky stuff going on and wanted to play it safe, and it wiped out the brief 5.0.5b update that Blizz had installed. That's probably the root of the problem--unsuccessfully re-updating and being caught in a loop. Thanks for teaching us how to force install and saving me a couple hours!
Bro, Skeinhammer, You are a legend and i want your babies!
I would enjoy having your babies as well.

Join the Conversation

Return to Forum