Quest phasing issues with Wulon

Bug Report

I have a large problem with the daily quest "Wulon, the Granite Sentinel". After accepting this quest, I flew down into the halls to go about killing him, only to find that the halls were completely empty. I thought this was really odd, normally there's dozens of people here and NPC bodies everywhere. I rounded the corner to Wulon's area and sure enough, he's not there.

So I ran back out into Vale, dropped the quest, picked it up again... same issue. I relogged and that didn't fix it. I also dropped the quest, relogged, and picked it up again... still broken.

I seem to be permanently stuck in some other phase (in halls only) where no NPCs, players, skeletons, or anything exist. Halfway down the hallway the speed runes on the ground disappear, then it's game over.

I'm really confused, and would love to complete this final daily for the chest, valor, and rep. How do I fix this?
Problem solved, I found that as my rep ticked over Revered with Golden Lotus, a new quest opened at the central hub that I had missed. As I progressed through this quest line, I was able to get back into the proper phase for Wulon.
That doesn't work for me, since Battle Helm of the Thunder King is bugged. Which is part of the quest chain picked up at Golden Pagoda when hitting revered........
I completed that quest line with no issues, and a guildmate also completed it a few hours ago (who also experienced the phase problem I had).

You have to actually speak with the Pandaran in the hallway, and wait for him to escort you to the helm before that specific part of the chain can be finished. I thought it was bugged too until I backtracked.
you cannot complete the new quest, and this DOES NOT FIX the problem. it's still broken. both the wulan and battle helm of thunderking quests are bugged and impossible to complete
Still having a phasing issue with ren during this quest. Followed him all the way to the helm and he phases out right after saying ugly. Can't click on the helm and ren isn't back at the entrance. Tried logging in/out and dropping and starting the quest over multiple times with the same result.
Bugged on Boulderfist as well, after I hit revered and am unable to complete the Battle Helm quest, due to a phasing issue and a known bug, I am now also unable to complete Wulon, the Granite Sentinel quest. Please fix this. As someone else pointed out, if you are going to insist that we get rep with these factions, at least allow the quests to be done. It is bad enough having to log in every day to complete the dailies, but to not be able to turn quests in going on 3 days, really really sucks.
It's bugged for me too and I'm not yet revered with Golden Lotus. The quest should not be available unless you can actually complete it.

Edit: Ranged classes have to actually get on the platform before Wulon will start attacking.

Join the Conversation

Return to Forum