Battle Helm of the Thunder King

Bug Report
Prev 1 2 3 4 23 Next
You wont be able to do the other quests inside the Halls until this is fixed. Both the Spider and the Quillen will be phased out.

So much for trying to rep grind.
Bugged for me as well on US Mug'thul. Also Phased into the halls and cannot finish killing Wulon.

Fix this ish already.
I just had a mini patch and confirm its still not lootable, because im phased on this quest i am now unable to complete Ashweb daily kill the spider in the halss due 2 the fact that im am phased. Even dropping the Helm quest still has me phased so that no spider is viewable. What a shiit show with these quest bugs. Being unable to open more daily quests coupled wit the lack of rep given from these factions really puts me behind others. Get an instant hotfix on this kinda nonsense
Same problem on US-Darkspear, npc phases out and can't finish the quest
Instant HotFix Needed NOW! Cannot progress through Daily quests due to being Phased! Can't kill Imperion as he just isn't there.

LIKE THIS POST IF YOU WANT A HOTFIX ASAP!!
I really think we should be compensated... I read on wowhead that this bug was on the PTR.
The only reason I finished my spider kill daily today is because my bf is not on this helm quest line and was able to see the spider and kill it lol

Tried cross-server invite to fix, no luck. Pet battle was also a flop - though worth a shot I suppose.
Been 48 hours with no Blue posts about this. Unbelievable.

You shove rep grinds down our throats and don't even bother to see if the quests work.
C'mon blizzard, please respond with ANYTHING concerning this rampant problem. Not working on Alleria either
I got a response from my ticket finally. Read this load of crap lol. Not going to post the GM name, but this is kinda ridiculous.

Greetings,

Thanks for bringing your concern to me today. I can see the importance of this issue and I want to make sure we get it fully resolved.

I understand you encountered an issue ingame that you want to report as a possible bug. In this case the issue was the despawning for the NPC Battle Helm of the Thunder King and I can see why you wanted to report this today. Due to the recent patch (and the massive amount of changes it brought upon the game world)we are evaluating all such reports closely to try to find and resolve any unintended changes or bugs as soon as possible.

You can always check our bug report forum found here: <http://us.battle.net/wow/en/forum/1012660/> For any updates and to see what is a known issue at this time/ what we have gotten reports about.

In the future if you have stumbled upon a bug, you can report it to the World of Warcraft Development & Quality Assurance teams, directly through the Customer Support window. In the Customer Support interface, click Submit Bug and fill out the requested information.

If we provide a update regarding this or if this becomes a known issue it should be posted in the bug forum at that time. I appreciate your time in making the World of Warcraft the best possible game it can be.

I hope you have found this information valuable today as my goal is to resolve your issue fully, and to provide you with the clear knowledge needed to get you back into the game as soon as possible. I know your time is valuable and as someone deeply invested in the service provided today I hope you found this explanation of how your issue was addressed clear, but if for any reason you need more help feel free to contact us again.

I would like to point out this part in particular,

"if this becomes a known issue it should be posted in the bug forum at that time."

REALLY!?!?! THIS IS A KNOWN ISSUE! And we have made several posts about it!
GMs pretty much just dole out canned responses now. That's what happens when you fire over half your support staff.
Bugged Azjol-Nerub too
Bugged on Lothar also, the fact that it was reported on beta and still happening is sad. Wonder how long it will take them to fix it.
I ran in to this bug right now too.
And I don't even see a single blue post on this.

This bug prevents you from progressing and should have been fixed days ago.
What are beta tests for if you can find and fix these kind of bugs before the final release...
Same problem on Proudmoore.
same thing on alexstrasza
wtb someone tht isnt bugged
I'm on gorg, I've tried 2 RealID friends from 2 other servers, I phased at least 12 times but still no Ren.

What will it take to get a Blue post on this? a lot of us became revered in the last couple of days and would like to progress through the quests
Its still bugged on icecrown too
Battle tag is Kiiyuth#1301 if anyone is online (Not on Kel'Thuzad) and is willing to give the work around a try.

EDIT: Doesn't seem to be working with the RealID work around. Might be server based. Maybe someone who has gotten it to work could invite?

Join the Conversation

Return to Forum