BossTargetFrame bug(?)

Bug Report
Not all my Boss#TargetFrames are showing.

I have disabled all addons, I moved my WTF folder elsewhere to clear settings, and I've deleted the cache.

Is there any setting I've missed which could be influencing this, or is this a flat out client bug?

Mac client btw.


More longwinded description of what happens:

I first noticed it on Stone Guard (10), only one of them was ever showing up. Because it was a scheduled raid I wasn't able to experiment with my UI properly, and I was always pulling the same mob first (Amethyst Guardian, on the far right).

Afterwards I experimented with Conclave of Wind in Tot4W using /framestack.

If I pull Anshal, sometimes Anshal flicks up briefly in Boss1TargetFrame before vanishing when Rohash shows up in Boss3TargetFrame. Rohash always stays in B3 permanently & the second frame never shows at all.

If I pull Rohash, then Anshal shows up in Boss1TargetFrame and Nezir shows up in Boss2TargetFrame. No third frame appears.

If i pull Nezir, then Nezir shows up in Boss1TargetFrame and Anshal shows up in Boss2TargetFrame. No third frame appears.
I am also on a mac, as are the 2 tanks in my guild. We were the only 3 people in raid last night that had issues with only one showing up. I'd love a solution!
Also having this issue. Tried to use MoveAnything to position them away from anything else to no avail, the same thing happens. One will show up, the others won't.
Any ideas?
After trying with totally clean cache/wtf & no addons, I enabled just Move Anything and continued to mess around.

As best I can see, it's not related to the bar positioning. I could reposition the bars fine, it'd accept the repositions, it didn't help.

It just either (a) isn't putting some of the boss bars up, (b) is removing them after it puts them up, or (c) both.

I'd try repairing my install but apparently it does that automatically now (/cynical stare).
Same problem here. I tried using a couple of unit frames addons (Pitbull and Shadowed Unit Frames) to try to work around the problem, but it didn't help.
I had exactly this same issue tonight, on a Mac client as well.

Extremely frustrating being a MT and completely blind to the bars on the different stone guards.

I only saw one boss target frame at a time. I disabled all addons with no change.
Just an update incase someone at Bliz is reading, we went in again last night... all 3 of us Mac guildies still had this issue, even running with no mods. :(
Glad someone posted about this. I am using the Mac client a well. Very frustrating.
Bump, this is happening right now to me, and I am a MT in my guild, pretty much causing wipes because I can't see which one I need to be taunting unless I tab through them all real fast. Mac OS. Please fix ASAP.
Ditto. Mac. No addons. One dog frame. Can't target, showstopper.
Another mac user here that only sees 1 boss frame on the Stone Guard, which means having to click nameplates. It's still doable, but a p.i.t.a.
I, too, am having this issue. I'm one of the tanks, and since watching/targeting/taunting the other tank's mobs without the boss frames feature is a giant pain (esp. with active mitigation, coupled with required separation, on a fight that is new to me), I end up wiping us a LOT, and the rest of the raid is getting pretty pissed at me.

Please fix this Blizzard!

Edit: of course, I too am a Mac user, and I don't have a PC option while this is worked out :(
Any type of blue acknowledgment that this post even exists would be nice.
Maybe we can get a moderator to move this to the Mac/Bug Report forum? It seems to be a Mac issue, maybe it will get addressed there more efficaciously.
Haveing same issue. (Mac)
Same problem Mac, running pitbull, tidy plates, dbm, acp, dominos, move everything, skada, skinner, and titan panel.
Glad to hear that I was not the only one with this problem, I was tanking the steno guards, and it was frustrating that I could only have one frame, and not all 3. I'm also on a mac, so I guess this is a client problem.
Yup, happened again last night. Spent hours wiping on what should be a straightforward tank swap fight. Would be nice to get some acknowledgement that this is being addressed.
Yeah I tried it with no add ons, and with ElvUI and DBM. Same deal either way.

Join the Conversation

Return to Forum