Issues running with wine + ubuntu

Technical Support
I'm currently running WoW on ubuntu with mild success. I have:

Ubuntu 12.04
Wine 1.4
Intel i7 with ivybridge graphics
Game client version 5.0.5

The three problems I'm currently experiencing are:

Problem #1 Graphics glitches in areas with fog (I think), that look like this:

http://ubuntuforums.org/attachment.php?attachmentid=225256&d=1349688992

Some locations look fine. I've tried messing with all display settings, with no success.

Problem #2: intermittent crashes, such as:

ERROR #134 (0x85100086) Fatal condition!

Program: Z:\home\rgt\Games\wow\drive_c\Program Files (x86)\World of Warcraft\Wow-64.exe
ProcessID: 86

Failed to read file from local.

Details: (Streaming Status: Enabled / Mfil Rdy / Data Rdy, Build: 16057)
[111] err=0 text=SFileReadFile - Character\NightElf\Male\NightElfMaleSkin00_08.blp - Data\texture.MPQ


The .MPQ file changes each time, but the error is otherwise identical. These occur anywhere between 5 minutes and an hour of play.

Problem #3: I can't seem to get the game to run with opengl - at least, the in game menu won't show it as an option. I've tried updating the config.wtf, as well as launching the game with -opengl, but neither work. I've read that opengl works better, however I have been getting decent frame rates (20-60), when issue #1 isn't occurring.

Any advice on any of the problems? Much appreciated!
Try updating Ubuntu or Wine? - Newer versions are out.

You probably need the new changes, as wine is on 1.5.14. You are a MAJOR patch behind + 15 minors.

And Ubuntu's latest is 12.10. I recommend updating them both and seeing if the problem persists.
Woohoo, it worked! Thanks

Join the Conversation

Return to Forum